1141. PAT Ranking of Institutions (25)

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where "ID" is a string of 6 characters with the first one representing the test level: "B" stands for the basic level, "A" the advanced level and "T" the top level; "Score" is an integer in [0, 100]; and "School" is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that "ID" is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where "Rank" is the rank (start from 1) of the institution; "School" is the institution code (all in lower case); "TWS" is the total weighted score which is defined to be the integer part of "ScoreB/1.5 + ScoreA + ScoreT*1.5", where "ScoreX" is the total score of the testees belong to this institution on level X; and "Ns" is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2
注意浮点型转换整型会丢失精度。 不必纠结是先取整再比较还是先比较再取整,两次就ok啦 分数相同,排名相同。要记录上一个学校的排名
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;

string ids, school;
double score;

struct Sch {
    string name;
    double score0, score1, score2;
    int tot;
    int cnt;
    int rank;
}sch[100001];

int n;
map<string ,int> _stoi;

string uptolow(string s) {
    for (int i = 0; i < s.length(); i++) {
        if (s[i] >= 'A' && s[i] <= 'Z') {
            s[i] -= ('A' - 'a');
        }
    }
    return s;
}
bool cmp(Sch sc1, Sch sc2) {
    if (sc1.tot != sc2.tot) return sc1.tot > sc2.tot;
    if (sc1.cnt != sc2.cnt) return sc1.cnt < sc2.cnt;
    return sc1.name < sc2.name;
}

int main() {
    freopen("input.txt", "r", stdin);   
    scanf("%d",&n);
    int tId = 1;

    for (int i = 0; i < n; i++) {
        cin>>ids>>score>>school;

        school = uptolow(school);

        int id = _stoi[school];

        if (id == 0) {
            id = tId;
            _stoi[school] = tId;
            tId++;
        }

        if (ids[0] == 'B') {
            sch[id].score0 += score;
        } else if (ids[0] == 'A') {
            sch[id].score1 += score;
        } else {
            sch[id].score2 += score;
        }
        sch[id].name = school;
        sch[id].cnt++;
    
    }
    printf("%d\n", tId-1);

    for (int i = 1; i < tId; i++) {
        sch[i].tot = (int)(sch[i].score0 / 1.5 + sch[i].score1 + sch[i].score2 * 1.5);
    }

    sort(sch+1, sch+tId, cmp);
    int preRank = 1;
    for (int i = 1; i < tId; i++) {
        if (i != 1 && sch[i].tot == sch[i-1].tot) {
            printf("%d ", preRank);
        }else {
            printf("%d ", preRank = i);
        }
        printf("%s %d %d\n", sch[i].name.c_str(), (int)sch[i].tot, sch[i].cnt);
    }
    
    return 0;
}
   

查看原文:http://iluhao.top/archives/727
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值