Description 求方程 的根,用三个函数分别求当b^2-4ac大于0、等于0、和小于0时的根,并输出结果。从主函数输入a、b、c的值。 Input a b c Output x1=? x2=

Description

求方程 的根,用三个函数分别求当b^2-4ac大于0、等于0、和小于0时的根,并输出结果。从主函数输入a、b、c的值。

Input

a b c

Output

x1=? x2=?

Sample Input

4 1 1

Sample Output

x1=-0.125+0.484i x2=-0.125-0.484i



#include <iostream>
#include<math.h>
#include<iomanip>
using namespace std;
void slove()
{
    float a,b,c,delta;
    while(cin>>a>>b>>c)
    {
        delta=b*b-4*a*c;
        if(delta>=0)
        {
            cout<<setiosflags(ios::fixed)<<setprecision(3)<<"x1="<<(-b+sqrt(delta))/(2*a)<<" "<<"x2="<<(-b-sqrt(delta))/(2*a)<<endl;
        }
        else
        {
            cout<<setiosflags(ios::fixed)<<setprecision(3)<<"x1="<<-b/(2*a)<<'+'<<sqrt(-delta)/(2*a)<<'i'<<" "<<"x2="<<-b/(2*a)<<'-'<<sqrt(-delta)/(2*a)<<'i'<<endl;
        }
    }
}
int main()
{
    slove();
    return 0;

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值