PAT:1003. Emergency (25)

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
第一行:n个城市,m条道路,从c1出发前往c2救火
每个城市有相应的救援人员数可以由你调用
第二行:n个城市每个城市的相应的可供调用的救援人员数
以下m行,第一个数字和第二个数字代表两座城市,第三个数字代表城市间的距离。
求有多少种最短的路径可以从c1到达c2  以及这几种方案中最多你可以带多少人过去

dijkstra做法,求最短路径,比较麻烦的是还要计算多少种方式以及路上最多可以带过去的人数




AC代码:
#include <iostream>
#include <algorithm>
#include <fstream>
#include <cstdlib>
#include <string>
#include <iomanip>
#include <sstream>
#include <cstring>
#include <stack>
#define MAX 8888888
using namespace std;
int main(){
    int n,m,c1,c2;
    cin>>n>>m>>c1>>c2;
    int a[508];
    int vis[508];
    int dis[508];
    int line[508][508];
    int path[508];
    int t_a[508];
    memset(a,0,sizeof(a));
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    memset(t_a,0,sizeof(t_a));
    for(int i=0;i<507;i++)
        for(int j=0;j<507;j++)
            line[i][j]=MAX;
    for(int i=0;i<n;i++){
        cin>>a[i];
        t_a[i]=a[i];
    }
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        cin>>line[a][b];
        line[b][a]=line[a][b];
    }
    for(int i=0;i<n;i++){
        dis[i]=line[c1][i];
        path[i]=1;
    }
    vis[c1]=1;
    dis[c1]=0;
    if(c2==c1){
cout<<1<<" "<<t_a[c1];
return 0;
}
    int k;
    while(vis[c2]==0){
        int l=MAX;
        for(int i=0;i<n;i++){
            if(vis[i]==0&&dis[i]<l){
                l=dis[i];
                k=i;
            }
        }
        vis[k]=1;
        for(int j=0;j<n;j++){
            if(vis[j]==0&&line[j][k]!=MAX){
                if(dis[j]>dis[k]+line[j][k]){
                    dis[j]=dis[k]+line[j][k];
                    path[j]=path[k];
                    t_a[j]=t_a[k]+a[j];
                }
                else if(dis[j]==dis[k]+line[j][k]){
                    dis[j]=dis[k]+line[j][k];
                    path[j]+=path[k];
                    t_a[j]=max(a[j]+t_a[k],t_a[j]);
                }
            }
        }
    }
    t_a[c2]+=a[c1];
    cout<<path[c2]<<" "<<t_a[c2]<<endl;
    return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值