PAT:1003. Emergency (25)

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
第一行:n个城市,m条道路,从c1出发前往c2救火
每个城市有相应的救援人员数可以由你调用
第二行:n个城市每个城市的相应的可供调用的救援人员数
以下m行,第一个数字和第二个数字代表两座城市,第三个数字代表城市间的距离。
求有多少种最短的路径可以从c1到达c2  以及这几种方案中最多你可以带多少人过去

dijkstra做法,求最短路径,比较麻烦的是还要计算多少种方式以及路上最多可以带过去的人数




AC代码:
#include <iostream>
#include <algorithm>
#include <fstream>
#include <cstdlib>
#include <string>
#include <iomanip>
#include <sstream>
#include <cstring>
#include <stack>
#define MAX 8888888
using namespace std;
int main(){
    int n,m,c1,c2;
    cin>>n>>m>>c1>>c2;
    int a[508];
    int vis[508];
    int dis[508];
    int line[508][508];
    int path[508];
    int t_a[508];
    memset(a,0,sizeof(a));
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    memset(t_a,0,sizeof(t_a));
    for(int i=0;i<507;i++)
        for(int j=0;j<507;j++)
            line[i][j]=MAX;
    for(int i=0;i<n;i++){
        cin>>a[i];
        t_a[i]=a[i];
    }
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        cin>>line[a][b];
        line[b][a]=line[a][b];
    }
    for(int i=0;i<n;i++){
        dis[i]=line[c1][i];
        path[i]=1;
    }
    vis[c1]=1;
    dis[c1]=0;
    if(c2==c1){
cout<<1<<" "<<t_a[c1];
return 0;
}
    int k;
    while(vis[c2]==0){
        int l=MAX;
        for(int i=0;i<n;i++){
            if(vis[i]==0&&dis[i]<l){
                l=dis[i];
                k=i;
            }
        }
        vis[k]=1;
        for(int j=0;j<n;j++){
            if(vis[j]==0&&line[j][k]!=MAX){
                if(dis[j]>dis[k]+line[j][k]){
                    dis[j]=dis[k]+line[j][k];
                    path[j]=path[k];
                    t_a[j]=t_a[k]+a[j];
                }
                else if(dis[j]==dis[k]+line[j][k]){
                    dis[j]=dis[k]+line[j][k];
                    path[j]+=path[k];
                    t_a[j]=max(a[j]+t_a[k],t_a[j]);
                }
            }
        }
    }
    t_a[c2]+=a[c1];
    cout<<path[c2]<<" "<<t_a[c2]<<endl;
    return 0;
}

                
以下是对提供的参考资料的总结,按照要求结构化多个要点分条输出: 4G/5G无线网络优化与网规案例分析: NSA站点下终端掉4G问题:部分用户反馈NSA终端频繁掉4G,主要因终端主动发起SCGfail导致。分析显示,在信号较好的环境下,终端可能因节能、过热保护等原因主动释放连接。解决方案建议终端侧进行分析处理,尝试关闭节电开关等。 RSSI算法识别天馈遮挡:通过计算RSSI平均值及差值识别天馈遮挡,差值大于3dB则认定有遮挡。不同设备分组规则不同,如64T和32T。此方法可有效帮助现场人员识别因环境变化引起的网络问题。 5G 160M组网小区CA不生效:某5G站点开启100M+60M CA功能后,测试发现UE无法正常使用CA功能。问题原因在于CA频点集标识配置错误,修正后测试正常。 5G网络优化与策略: CCE映射方式优化:针对诺基亚站点覆盖农村区域,通过优化CCE资源映射方式(交织、非交织),提升RRC连接建立成功率和无线接通率。非交织方式相比交织方式有显著提升。 5G AAU两扇区组网:与三扇区组网相比,AAU两扇区组网在RSRP、SINR、下载速率和上传速率上表现不同,需根据具体场景选择适合的组网方式。 5G语音解决方案:包括沿用4G语音解决方案、EPS Fallback方案和VoNR方案。不同方案适用于不同的5G组网策略,如NSA和SA,并影响语音连续性和网络覆盖。 4G网络优化与资源利用: 4G室分设备利旧:面对4G网络投资压减与资源需求矛盾,提出利旧多维度调优策略,包括资源整合、统筹调配既有资源,以满足新增需求和提质增效。 宏站RRU设备1托N射灯:针对5G深度覆盖需求,研究使用宏站AAU结合1托N射灯方案,快速便捷地开通5G站点,提升深度覆盖能力。 基站与流程管理: 爱立信LTE基站邻区添加流程:未提供具体内容,但通常涉及邻区规划、参数配置、测试验证等步骤,以确保基站间顺畅切换和覆盖连续性。 网络规划与策略: 新高铁跨海大桥覆盖方案试点:虽未提供详细内容,但可推测涉及高铁跨海大桥区域的4G/5G网络覆盖规划,需考虑信号穿透、移动性管理、网络容量等因素。 总结: 提供的参考资料涵盖了4G/5G无线网络优化、网规案例分析、网络优化策略、资源利用、基站管理等多个方面。 通过具体案例分析,展示了无线网络优化中的常见问题及解决方案,如NSA终端掉4G、RSSI识别天馈遮挡、CA不生效等。 强调了5G网络优化与策略的重要性,包括CCE映射方式优化、5G语音解决方案、AAU扇区组网选择等。 提出了4G网络优化与资源利用的策略,如室分设备利旧、宏站RRU设备1托N射灯等。 基站与流程管理方面,提到了爱立信LTE基站邻区添加流程,但未给出具体细节。 新高铁跨海大桥覆盖方案试点展示了特殊场景下的网络规划需求。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值