HDU1528-二分图最小点覆盖

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1880    Accepted Submission(s): 1038


Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

Sample Input
  
  
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D
 

Sample Output
  
  
1 1 2
 

题目大意

                 给你和你朋友一人n张牌,你知道你朋友的出牌顺序,问你怎么安排你的出牌顺序才能使你的得分最高,输出最高得分,两张牌如果点数相同则按花色,如果都相同都不得分,具体见题目描述


题目思路:

                  这题其实就是田忌赛马的变形体,可以用贪心做,也可以用二分图做,这里我用的是二分图,首先我们考虑怎么建图,我们知道最后是要你的得分最高,所以如果你的牌的大于他的牌那么你可以连一条边,你的牌为一个集合,他的牌为一个集合,最后的模型就是选取最少的点使得所有边的至少一个端点被选中,即最小点覆盖模型,而最小点覆盖就是最大匹配,所以我们进行最大匹配的答案就是我们要求的


AC代码:

#include<cstring>
#include<cstdio>

const int maxn = 30;

bool vis[maxn],mp[maxn][maxn];
int link[maxn];
int com[127];
int n;

bool dfs(int u){
    for(int i=1;i<=n;i++){
        if(!vis[i]&&mp[u][i]){
            vis[i]=true;
            if(link[i]==-1||dfs(link[i])){
                link[i]=u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    com['H'-'1']=4,com['S'-'1']=3,com['D'-'1']=2,com['C'-'1']=1;   //预处理牌的大小
    com['1'-'1']=1,com['2'-'1']=2,com['3'-'1']=3,com['4'-'1']=4;
    com['5'-'1']=5,com['6'-'1']=6,com['7'-'1']=7,com['8'-'1']=8;
    com['9'-'1']=9,com['T'-'1']=10,com['J'-'1']=11,com['Q'-'1']=12;
    com['K'-'1']=13,com['A'-'1']=14;
    int t;scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        memset(link,-1,sizeof(link));
        memset(mp,false,sizeof(mp));
        char str[30][5];
        for(int i=1;i<=n;i++){
            scanf("%s",str[i]);
        }
        for(int i=1;i<=n;i++){
            char ch[5];
            scanf("%s",ch);
            for(int j=1;j<=n;j++){
                if(com[ch[0]-'1']>com[str[j][0]-'1']||com[ch[0]-'1']==com[str[j][0]-'1']&&com[ch[1]-'1']>com[str[j][1]-'1'])
                        mp[i][j]=true;
            }
        }
        int ans = 0;
        for(int i=1;i<=n;i++){
            memset(vis,false,sizeof(vis));
            if(dfs(i))ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值