机试之字符串匹配——HDU1711-Number Sequence

机试之字符串匹配——HDU1711-Number Sequence

1、KMP原理及代码

1.1KMP原理

KMP是字符串匹配的一种较好的算法。字符串匹配在字符串的应用中很常见,其常见的方法有:
直接循环逐个比较,不符合则子串指针归零,母串指针下移一位,可参考如下例子
在这里插入图片描述
这种方法耗时太大,为了进一步改进,大佬们开发了KMP算法。KMP算法是对直接逐个比较的改进,所以其也是进行循环比较,不同之处在于匹配不符后,子串指针仍归为0,但是母串指针要找到一个在失配后面最符合的一个位置处,于是引入nextTable[]数组,专门来存储该信息。
在这里插入图片描述

1.2KMP代码

//机试之字符串匹配
//理论部分没听懂 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXM = 100;
int nextTable[MAXM];

void GetNextTable(string pattern){//构造next数组 
	int m = pattern.size();//获取模式串大小
	int j = 0;
	nextTable[j] = -1;
	int t = nextTable[j];
	while(j < m){
		if(t == -1 || pattern[t] == pattern[j]){
			++t;
			++j;
			nextTable[j] = t;
		}
		else{
			t = nextTable[t];
		}
	}
} 

int KMP(string text,string pattern){//文本串和模式串,返回第一次匹配成功的文本串上的下标 
	GetNextTable(pattern);//构造next数组 
	int n = text.size();
	int m = pattern.size();
	int i = 0, j = 0;
	while(i < n && j < m){
		if(j == -1 || text[i] == pattern[j]){
			++i;
			++j;
		}
		else{
			j = nextTable[j];
		}
	}
	if(j == m){
		return i - j;
	}
	else{
		return -1;
	}
}
int main(){
	string text,pattern;
	text = "I love you";
	pattern = "love";
	int pos = KMP(text,pattern);
	cout<<pos<<endl; 
    return 0;
}

2、例题HDU1711Number Sequence

2.1题目

题目链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1711

                                          **Number Sequence**
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 58011    Accepted Submission(s): 23152

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
 

Source
HDU 2007-Spring Programming Contest

2.2代码

//机试之字符串匹配——HDU1711Number Sequence
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 1000000;
const int MAXM = 10000;
int nextTable[MAXM];
int text[MAXN];
int pattern[MAXM];

void GetNextTable(int m){//构造next数组 
	int j = 0;
	nextTable[j] = -1;
	int t = nextTable[j];
	while(j < m){
		if(t == -1 || pattern[t] == pattern[j]){
			++t;
			++j;
			nextTable[j] = t;
		}
		else{
			t = nextTable[t];
		}
	}
} 

int KMP(int n, int m){//文本串和模式串,返回第一次匹配成功的文本串上的下标 
	GetNextTable(m);//构造next数组 
	int i = 0, j = 0;
	while(i < n && j < m){
		if(j == -1 || text[i] == pattern[j]){
			++i;
			++j;
		}
		else{
			j = nextTable[j];
		}
	}
	if(j == m){
		return i - j;
	}
	else{
		return -1;
	}
}
int main(){
	int T;
//	cin>>T;
	scanf("%d",&T);
	while(T--){//样例数 
		int n,m;//文本串包含数个数与模式串包含数个数 
	//	cin>>n>>m;
		scanf("%d%d",&n,&m);
		for(int i = 0; i < n; ++i){//输入文本串 
		//	cin>>text[i];
			scanf("%d",&text[i]);
		}
		for(int i = 0; i < n; ++i){//输入模式串 
		//	cin>>pattern[i];
			scanf("%d",&pattern[i]);
		}
		int res = KMP(n,m);
		if(res == -1){
		//	cout<<-1<<endl;
			printf("-1\n");
		}
		else{
		//	cout<<KMP(n,m)+1<<endl; 
			printf("%d\n",KMP(n,m)+1);
		}
	}
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

李霁明

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值