.cur 图片加载提示 You may need an appropriate loader to handle this file type

最近一个gis 项目需要加载一个.cur的图标,但是编译时提示

You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders (Source code omitted for this binary file)

显然是少配置了一个loader,接下来就开始配置

cli2 直接在webpack.base.config.js的module的 rules中新增如下配置即可

      {
        test: /\.(cur)(\?.*)?$/,
        loader: 'url-loader',
        options: {
          limit: 10000,
          name: utils.assetsPath('cur/[name].[hash:7].[ext]')
        }
      },

而cli3 就更简单了,直接在vue.config.js中新增如下配置


    chainWebpack: config => {
        config.module
            .rule('url-loader')
            .test(/\.(cur)(\?.*)?$/)
            .use('url-loader')
            .loader('url-loader')
            .end()
    },
    

配置详情可以参考官网 https://cli.vuejs.org/guide/webpack.html#adding-a-new-loader

特此记录希望对有需要的伙伴一点帮助

发布了118 篇原创文章 · 获赞 27 · 访问量 8万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览