POJ-2823Sliding Window(单调队列模板)

64 篇文章 0 订阅
53 篇文章 1 订阅

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 58321 Accepted: 16711
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意:给你n个数字,然后问你任意连续的k个数字的最大值最小值分别是多少,按照顺序分别输出

解题思路:这道题涉及到是单调队列的问题,主要是通过n个数一次加入队列中与前面的数字进行比较,要是符合条件则T掉前面的数字,知道不符合条件或者直到队列中不存在任何数,同时要判是否在队列首位(最大值或者最小值)已经超出了目前k个数字的限制,超过后,要将队列的首位往后移动该数字的在n个数字的索引值满足当前的k个数字的限制

#include<iostream>  
#include<cstdio>
#include<stdio.h>
#include<cstring>  
#include<cstdio>  
#include<climits>  
#include<cmath> 
#include<vector>
#include <bitset>
#include<algorithm>  
#include <queue>
#include<map>
#define INF 2147483647
using namespace std;
int maxnum[1000006], minnum[1000006], n, k, i, a[1000006], cur;
int li, la, ri, ra;

struct node
{
	int index;
	int number;
};
node qui[1000005];
node qua[1000005];
int main()
{
	scanf("%d %d", &n, &k);
	for (i = 1; i <= n; i++)
	{
		scanf("%d", &a[i]);
	}
	ri = ra = 1;
	li = la = 1;
	qui[1].number = INF;
	qua[1].number = -INF;
	//第一组前k值算出最大的和最小的
	for (i = 1; i <= k; i++)
	{
		node temp;
		temp.index = i;
		temp.number = a[i];
		while (li <= ri&&qui[ri].number >= a[i])
		{
			--ri;
		}
		++ri;
		qui[ri] = temp;
		while (la <= ra&&qua[ra].number <= a[i])
		{
			--ra;
		}
		++ra;
		qua[ra] = temp;
	}
	cur = 1;
	for (i = k + 1; i <= n; i++)
	{//把首位加入到最终数组,意味着这符合条件
		minnum[cur] = qui[li].number;
		maxnum[cur] = qua[la].number;
		cur++;
		node temp;
		temp.index = i;
		temp.number = a[i];

		while (li <= ri&&qui[ri].number >= a[i])
		{
			--ri;
		}
		++ri;
		qui[ri] = temp;
		while (la <= ra&&qua[ra].number <= a[i])
		{
			--ra;
		}
		++ra;
		qua[ra] = temp;
		while (li < ri&&qui[li].index < i - k + 1)
		{
			li++;
		}
		while (la < ra&&qua[la].index < i - k + 1)
		{
			la++;
		}
	}
	for (i = 1; i < cur; i++)
	{
		printf("%d ", minnum[i]);
	}
	printf("%d\n", qui[li].number);
	for (i = 1; i < cur; i++)
	{
		printf("%d ", maxnum[i]);
	}
	printf("%d\n", qua[la].number);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值