Sliding Window(单调队列)

Sliding Window
Time Limit: 12000MS  Memory Limit: 65536K
Total Submissions: 35975  Accepted: 10649
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

 

      题意同上题。

 

       思路:

       单调队列。一个单调队列保存非递增序列,一个单调队列维护非递减序列。当滑动一个窗口时就将新元素与最后一个元素比较,后插入队尾。输出的时候输出队头元素,要判断队头元素下标是否符合当前的 l,r 值范围内。

      

       AC:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX = 1000005;

int n, k;
int num[MAX];
int q_max[MAX], q_min[MAX];

void Max () {
        int s = 0, e = -1;
        int l = 1, r = 1 + k - 1;
        q_max[++e] = 1;
        for (int i = l; i <= r; ++i) {
                if(num[i] <= num[q_max[e]]) q_max[++e] = i;
                else {
                        while(num[i] > num[q_max[e]] &&
                              e != s - 1) --e;
                        q_max[++e] = i;
                }
        }
        printf("%d", num[q_max[s]]);

        for (++l, ++r; r <= n; ++l, ++r) {
                if (num[r] <= num[q_max[e]]) q_max[++e] = r;
                else {
                        while(num[r] > num[q_max[e]] &&
                              e != s - 1) --e;
                        q_max[++e] = r;
                }
                while (q_max[s] > r || q_max[s] < l) ++s;
                printf(" %d",num[q_max[s]]);
        }
        printf("\n");
}

void Min () {
        int s = 0, e = -1;
        int l = 1, r = 1 + k - 1;
        q_min[++e] = 1;
        for (int i = l; i <= r; ++i) {
                if(num[i] >= num[q_min[e]]) q_min[++e] = i;
                else {
                        while(num[i] < num[q_min[e]] &&
                              e != s - 1) --e;
                        q_min[++e] = i;
                }
        }
        printf("%d", num[q_min[s]]);

        for (++l, ++r; r <= n; ++l, ++r) {
                if (num[r] >= num[q_min[e]]) q_min[++e] = r;
                else {
                        while(num[r] < num[q_min[e]] &&
                              e != s - 1) --e;
                        q_min[++e] = r;
                }
                while (q_min[s] > r || q_min[s] < l) ++s;
                printf(" %d",num[q_min[s]]);
        }
        printf("\n");
}

int main () {

        while (~scanf("%d%d", &n, &k)) {

                for (int i = 1; i <= n; ++i)
                        scanf("%d", &num[i]);

                Min();

                Max();
        }

        return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值