POJ3660Cow Contest(floyed算法模板)

64 篇文章 0 订阅
53 篇文章 1 订阅
Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11015 Accepted: 6128

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

题目大意:有n个神奇的奶牛会编码,然后之间进行了比赛,一共进行了m场比赛,然后问你m场比赛过后能够确定排名的奶牛有几个

解题思路:这道题之前想的是用拓扑排序,但是发现好像不行,但是顺手好歹学会了拓扑排序,这套题用的是floyed算法,这个算法一开始是用来算最短路的,然后这次用来记录是否A奶牛与B奶牛之间是否能确定胜负关系,通过其他奶牛,或者直接通过两者确定,然后学到两点关于拓扑排序和这方面题呢

1.确定该点是否排名确定,可以通过该点的入度+出度==n-1来判断

2.在拓扑排序当中,如果他这个点之前删除的点数与他的入度相同,意味着这个点的排名确定

另外floyed算法的关键是三层循环,(On……3)的时间,这个比较经典

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

int a[105][105], n, m;
void floyed()
{
	int i, j, k;
	for (k = 1; k <= n; k++)
	{
		for (i = 1; i <= n; i++)
		{
			for (j = 1; j <= n; j++)
			{
				if (a[i][j] == 1 || a[i][k] == 1 && a[k][j] == 1)
				{
					a[i][j] = 1;
				}
			}
		}
	}
}
int main()
{
	int i, x, y, ans, sum, j;
	cin >> n >> m;
	memset(a, 0, sizeof(a));
	for (i = 1; i <= m; i++)
	{
		cin >> x >> y;
		a[x][y] = 1;
	}
	floyed();
	sum = 0;
	for (i = 1; i <= n; i++)
	{
		ans = 0;
		for (j = 1; j <= n; j++)
		{
			if (a[i][j] == 1 || a[j][i] == 1)
			{
				ans++;
			}
		}
		if (ans == n - 1)
		{
			sum++;
		}
	}
	cout << sum << endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值