POJ - 1050 To the Max(区间DP最大字串和,最大子矩阵和模板)

64 篇文章 0 订阅
53 篇文章 1 订阅
To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48400 Accepted: 25619

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

题目大意:在一个矩阵之中找出和最大的子矩阵,输出子矩阵最大和为多少

解题思路:这是一道区间DP的计算,这段时间的恶补,还是有一些成效的,这道题最简单的想法是从一维开始想

一维就是求最大字符串和,也就是设置为

dp[k]=max(0,dp[k-1]+a[k]);
ans=max(ans,dp[k])

其中dp[k]指的是从前面某一个位置开始的最大和,要是dp[k-1]小于0则从k位置重新开始找最大和,这个逻辑应该能明白,100和100+(-1)肯定是100最大,所以当dp的值小于0就直接舍弃了,然后每次判一下最大值ans存的是k-1的时候最大的字符串和

延伸到二维数组里面,就是列不停地压缩,压缩到一行上,然后卡住头尾行数重复一维的操作获得最大值

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

int dp[105], a[105][105], sum[105][105], ans, i, j, n, k;
int main()
{
	cin >> n;
	memset(sum, 0, sizeof(sum));
	for (i = 1; i <= n; i++)
	{
		for (j = 1; j <= n; j++)
		{
			cin >> a[i][j];
		}
	}
	for (i = 1; i <= n; i++)
	{
		for (j = 1; j <= n; j++)
		{
			sum[i][j] = sum[i - 1][j] + a[i][j];//计算前i行的和
		}
	}
	ans = -10000000;
	for (i = 1; i <= n; i++)
	{
		for (j = i; j <= n; j++)
		{
			memset(dp, 0, sizeof(dp));
			for (k = 1; k <= n; k++)
			{
				if (dp[k-1] >= 0)//sum[j][k] - sum[i][k]表示以i+1行开始j行结束时候列的和
				{
					dp[k] +=dp[k-1]+ sum[j][k] - sum[i][k];
				}
				else
				{
					dp[k] = sum[j][k]-sum[i][k];
				}
				ans = max(ans, dp[k]);
			}
		}
	}
	cout << ans << endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值