POJ1159Palindrome(区间dp回文串最长公共子序列+滚动数组模板)

64 篇文章 0 订阅
53 篇文章 1 订阅
Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 62457 Accepted: 21761

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

题目大意:给一个字符串,求组成一个字符串成回文串能够最少增加几个字符

解题思路:回文串基本上就是遇到不会的状况,除非水到不行的题,这道题用到了最长公共子序列,方法就是你要把字符串从头存一个,从尾存一个,然后进行比较,在代码中,下面的代码是最重要的

if (a[i] == b[j])
			{
				dp[e][j] = dp[1 - e][j - 1] + 1;
			}
			else
			{
				dp[e][j] = max(dp[e][j - 1], dp[1 - e][j]);
			}

然后考虑到数据5000,开二维数组完全是不可能的,所以为了能够解决问题,减少内存,运用了滚动数组的概念,这个概念是从网上找的,所以我就先看看,会了就补上来

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

int dp[5][5005], i, n, e, j;
char a[5005], b[5005];
int main()
{
	cin >> n;
	for (i = 1; i <= n; i++)
	{
		cin >> a[i];
		b[n - i + 1] = a[i];
	}
	memset(dp, 0, sizeof(dp));
	e = 0;
	for (i = 1; i <= n; i++)
	{
		e = 1 - e;
		for (j =1; j <= n; j++)
		{
			if (a[i] == b[j])
			{
				dp[e][j] = dp[1 - e][j - 1] + 1;
			}
			else
			{
				dp[e][j] = max(dp[e][j - 1], dp[1 - e][j]);
			}
		}
	}
	cout << n-dp[e][n] << endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值