POJ3665iCow

iCow
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6397 Accepted: 2332

Description

Fatigued by the endless toils of farming, Farmer John has decided to try his hand in the MP3 player market with the new iCow. It is an MP3 player that stores N songs (1 ≤ N ≤ 1,000) indexed 1 through N that plays songs in a "shuffled" order, as determined by Farmer John's own algorithm:

  • Each song i has an initial rating Ri (1 ≤ Ri ≤ 10,000).
  • The next song to be played is always the one with the highest rating (or, if two or more are tied, the highest rated song with the lowest index is chosen).
  • After being played, a song's rating is set to zero, and its rating points are distributed evenly among the other N-1 songs.
  • If the rating points cannot be distributed evenly (i.e., they are not divisible by N-1), then the extra points are parceled out one at a time to the first songs on the list (i.e., R1 , R2 , etc. -- but not the played song) until no more extra points remain.
This process is repeated with the new ratings after the next song is played.

Determine the first T songs (1 ≤ T ≤ 1000) that are played by the iCow.

Input

* Line 1: Two space-separated integers: and T
* Lines 2..N+1: Line i+1 contains a single integer: Ri

Output

* Lines 1..T: Line i contains a single integer that is the i-th song that the iCow plays.

Sample Input

3 4
10
8
11

Sample Output

3
1
2
3

Source

题目题意:

有一款MP3,叫iCow,里面存储了N(1<=N<=1000)首歌曲,随机播放顺序由以下决定。

• 每首歌i有一个初始的Ri(1<=Ri<=10000)
• 下首歌总是最高的Ri(如果Ri==Rj && i<j,则选i)
• 一首歌i播放之后,这首歌的Ri=0,并且将这首歌原来的Ri分给其他N-1首歌
• 若Ri不能被N-1整除,则多出的部分Ri%(N-1)将从第1首歌开始一首歌1点(播放的这首歌除外),直到没有多余的点数
每首歌播放完毕都执行以上算法更新Ri

请决定先被播放的T(1<=T<=1000)首歌曲。

输出T行,代表每次播放哪首歌。

解题思路:纯模拟

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

int n, T, i, j, ans, k;
struct song
{
	int i;
	int ans;
}s[1005];
bool cmp(song x, song y)
{
	if (x.ans == y.ans)
	{
		return x.i < y.i;
	}
	else
	{
		return x.ans > y.ans;
	}
}
bool cmp1(song x, song y)
{
	return x.i < y.i;
}
int main()
{
	cin >> n >> T;
	for (i = 1; i <= n; i++)
	{
		cin >> s[i].ans;
		s[i].i=i;
	}
	while (T--)
	{
		sort(s + 1, s + 1 + n, cmp);
		ans = s[1].ans;
		k = s[1].i;
		cout << k << endl;
		s[1].ans = 0;
		sort(s + 1, s + 1 + n, cmp1);
		j = ans / (n - 1);
		ans %= n - 1;
		for (i = 1; i <= n; i++)
		{
			if (i != k)
			{
				s[i].ans += j;
			}
			if (ans != 0&&i!=k)
			{
				s[i].ans++;
				ans--;
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值