HDU - 5045 2014 ACM/ICPC Asia Regional Shanghai Online D - Contest (状压DP)

25 篇文章 4 订阅
24 篇文章 0 订阅

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1820    Accepted Submission(s): 735


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the i th student solve the j th problem, the probability of correct solve is P ij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the j th number in the i th line is P ij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
  
  
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
  
  
Case #1: 2.20000
 

Source
 

Recommend
hujie
 

题目大意:有n人和m题要求去做,每个人对每个题存在一个写对的概率,现在要求获得最高的概率,限制条件在于在任何一个时刻,写题最多的人比写题最少的人差距不超过一道题
解题思路:考虑到求极值,且是存在着某一种状态,所以是选择状压DP,同时为了保证满足条件,所以要将m题分成m/n轮,这样能够保证满足条件,对此状态我们可以利用状压去解决
#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map> 
#define inf 9999999; 
using namespace std;

double sum;
double dp[1050][1050],a[20][1050];
int n,m,i,j,k,t,T,st;
int main()
{
	t=0;
	cin>>T;
	while(T--)
	{
		//n=m=k=0;
		//sum=0;
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		t++;
		cin>>n>>m;
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				cin>>a[i][j];
		//int ans=(1<<n)-1;
		for(i=0;i<1050;i++)
			for(j=0;j<1050;j++)
				dp[i][j]=-1.0;//dp[i][j]表示做了i题后目前的状态是j
		dp[0][0]=0;
		//int sum;	
		for(i=1;i<=m;i++)
		{
			for(j=0;j<(1<<n);j++)
			{
				if(dp[i-1][j]<0) continue;
				for(k=0;k<n;k++)
				{
					if(!(j&(1<<k)))//此时这个人是否已经在这一轮中做过题
					{
						st=j|(1<<k);//同步此时这个人做题后的这一轮的做题情况
						if(st==(1<<n)-1) st=0;//假设n为2 从001->100减一后就是11也就是两个人都做过题了,所以就说明这轮的做题情况结束了
						dp[i][st]=max(dp[i][st],dp[i-1][j]+a[k+1][i]);//st这个状态是通过j这个状态转变而来的,而k+1的原因是,考虑到1左移的位数其实是位数加+1这个人的概率值,因为二进制有一个2的0次方的问题
						
					}
				}
			}
		}
		sum=0;
		for(i=0;i<(1<<n);i++)
		{
			sum=max(sum,dp[m][i]);
			//cout<<"hahah   "<<dp[m][i]<<endl;
		}
		printf("Case #%d: %.5lf\n", t, sum);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值