HDU6045 2017 Multi-University Training Contest - Team 2 A - Is Derek lying?

64 篇文章 0 订阅
25 篇文章 4 订阅

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 330    Accepted Submission(s): 199


Problem Description
Derek and Alfia are good friends. Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia .Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X ,your total score is Y .”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N , X , Y ,the meaning is mentioned above.

The second line consists of N characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that Derek is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying
 

Source
 

Recommend
liuyiding
 

题目大意:存在T组数据,每个数据有n道题目,有两个人分别答对X和Y道题,现在告诉你这两个人的所有选择题的回答,问是否存在对于两个人答对的答案说谎的可能性
解题思路:切入点是两个人回答相同的题的题数,对于答对较少的来说,若是他答对的比相同题的题数都少,这意味着对于答对多的人,他需要在不同答案的那些题里面答对很多,以此判断是否说谎
若是答对的题较少的人来说,他答对的比相同题的题数多,你需要判断那些对于这两个人来说,他们共同减去相同题的题数后,是否能合理分配那些不同答案题数
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

LL pt=1e9+7;
LL cnt,sum;
LL a[250010],ans[250010];
int b[250010],n;
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
	while(cin>>n)
	{
		int i;
		memset(ans,0,sizeof(ans));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=1;i<=n;i++) 
		{
			cin>>a[i];
			a[i]-=i;
		}
		ans[n]=a[n];
		for(i=n-1;i>=1;i--)
			ans[i]=max(a[i],ans[i+1]);
		for(i=1;i<=n;i++) cin>>b[i];
		sort(b+1,b+1+n);
		sum=0;
		cnt=0;
		for(i=1;i<=n;i++)
		{
			if(cnt<ans[b[i]])
				sum=(sum+ans[b[i]])%pt;
			else
				sum=(sum+cnt)%pt;
			cnt=max(cnt,ans[b[i]]-(n+i));
		}
		cout<<sum<<endl;
			
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值