2017 Multi-University Training Contest - Team 9 Numbers (实力乱搞)

64 篇文章 0 订阅
25 篇文章 4 订阅

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 61    Accepted Submission(s): 25


Problem Description
zk has n numbers a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number (ai+aj) . These new numbers could make up a new sequence b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each ai is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6170  6169  6168  6167  6166 
 

题目大意:A数组中任意两个元素相加和组成数组B,现在两个数组混合在一起,要求把A数组筛出来
解题思路:这道题想倒是没有想偏,只是没有触到核心点,首先将数组排序,然后在输入的时候每个数字出现的次数用map存储好,同时将最小的两个数字从map中--,他们俩为A数组中的两个数字,然后枚举出通过已经确定A数组相加获得数字,map--,然后在check数组从小找第一个map不为0得数字,为A数组得元素,然后以此类推
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

map<LL,int> cnt;
LL a[125255],b[125250];
int n,m,pos;
int main()
{
	while(scanf("%lld", &n) != EOF)
	{
		int i,k;
		cnt.clear();
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=1;i<=n;i++)
		{
			if(i*(i+1)/2==n)
			{
				m=i;
				break;
			}
		}
		pos=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			cnt[a[i]]++;
		}
		sort(a+1,a+1+n);
		b[1]=a[1];
		b[2]=a[2];
		cnt[a[1]]--;
		cnt[a[2]]--;
		pos=2;
		k=3;
		for(;;)
		{
			for(i=1;i<pos;i++)
			{
				cnt[b[i]+b[pos]]--;
			}
			for(i=k;i<=n;i++)
			{
				if(cnt[a[i]]!=0)
				{
					cnt[a[i]]--;
					k=i+1;
					b[++pos]=a[i];
					break;
				}
			}
			if(pos==m)
				break;
		}
		cout<<m<<endl;
		for(i=1;i<m;i++)
			printf("%lld ",b[i]);
		printf("%lld\n",b[i]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值