POJ3273Monthly Expense(二分)

3 篇文章 0 订阅
Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29158 Accepted: 11077

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

题目大意:要求将N个数字分成K组,每组经可能小,求K组中最大的值

解题思路:一般这种最大值最小值最好的办法就是用二分,我二分每组大小限制,然后去check在这个范围下是否能够生成K组

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

int n,k;
int a[100005];
bool check(int x)
{
	int i,flag;
	int cnt=0;
	flag=0;
	for(i=1;i<=n;i++)
	{
		if(cnt+a[i]>x)
		{
			flag++;
			cnt=a[i];
		}
		else
			cnt+=a[i];
	}
	if(flag+1<=k)
		return true;
	else
		return false;
}
int main()
{
	int l,r,i,sum,ans,mid;
	cin>>n>>k;
	sum=0;
	for(i=1;i<=n;i++)
	{
		cin>>a[i];
		sum+=a[i];
	}
	l=0,r=sum;
	while(l<r-1)
	{
		mid = (l+r)/2;
		if(check(mid))
		{
			r=mid;
		}
		else
		{
			l=mid;
		}
	}
	sum=0,ans=0;
	for(i=1;i<=n;i++)
	{
		if(ans+a[i]>r)
		{
			sum=max(sum,ans);
			ans=a[i];
		}
		else
			ans+=a[i];
	}
	cout<<sum<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值