hdu3037 LUCAS定理运用。

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4440    Accepted Submission(s): 1738


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
 

Output
You should output the answer modulo p.
 

Sample Input
  
  
2 1 2 5 2 1 5
 

Sample Output
  
  
3 3

题意可以转化成 求 x1+x2+x3+...xn<=m的解;x1+x2+x3...xn=m的解用隔板法,将 n+m-1取m个的方法就是解的个数 及 ans=sum(c(n+m-1,m))  m从0到m;

C(n,k) = C(n-1,k)+C(n-1,k-1) 从而得到 ans=c(n+m,m);然后就可以用lucas了    C(n,m)%p=C(n/p,m/p)*C(n%p,m%p)%p

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long int llg;

const int N =150000;

llg n, m, p, fac[N];

void init()
{
    int i;
    fac[0] =1;
    for(i =1; i <= p; i++)
        fac[i] = fac[i-1]*i % p;
}

llg pow(llg a, llg b)
{
    llg tmp = a % p, ans =1;
    while(b)
    {
        if(b &1)  ans = ans * tmp % p;
        tmp = tmp*tmp % p;
        b >>=1;
    }
    return  ans;
}

llg C(llg n, llg m)
{
    if(m > n)  return 0;
    return  fac[n]*pow(fac[m]*fac[n-m], p-2) % p;
}

llg Lucas(llg n, llg m)
{
    if(m ==0)  return 1;
    else return  (C(n%p, m%p)*Lucas(n/p, m/p))%p;
}

int main()
{
   int T;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%I64d%I64d%I64d",&n,&m,&p);
       init();
       printf("%I64d\n",Lucas(m+n,m));
   }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值