(六)STL解决括号匹配问题

                                     STL解决括号匹配问题

输入

由括号构成的字符串,包含”(“、”)“、”[“和”]“。

输出

如果匹配输出YES,否则输出NO。

样例输入

[([][]())]

样例输出

YES
// 12括号匹配问题.cpp: 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include <string>
#include <vector>
#include <map>
#include <iostream>
using namespace std;

int main()
{
	vector<char> Stack;
	map<char,char> map1;
	int i = 0;
	int weight = 0;
	char pop;
	string data;
	map1.insert(pair<char, char>('[',']'));
	map1.insert(pair<char, char>('(',')'));
	map1.insert(pair<char, char>('{', '}'));
	cin >> data;
	while (i < data.length()) {
		if (data[i]=='(' || data[i]=='[' || data[i] == '{') {
			Stack.push_back(data[i]);
		}
		else {
			if (Stack.size()) {
				pop = Stack.back();
				Stack.pop_back();
				if (data[i] != map1[pop]) {
					break;
				}
			}
			else {
				cout << "NO";
				return 0;
			}
		}
		i++;
	}
	if (Stack.size()!=0) {
		cout << "NO";
	}
	else {
		cout << "YES";
	}
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值