poj 1068 Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24821 Accepted: 14621

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

这题可以说是今天我做过的水题了(请允许我这样说,我知道那些大神们认为我今天做的都是水题 Q7Q)
题的大意是(以下是我搜索的啊)
/*
此题多组处理数据,每组输入n个数,每个a[i]代表当前对应的右括号前面共有多少个左括号。
    比如:n=6, 4 5 6 6 6 6 。 对应第一个右括号前有4个左括号,第二个右括号前有5个左括号,不过千万不要落下第一个右括号啊,以此类推下去。。。。。。   
     现在要求输出另一个数组,数组元素为当前右括号包含的括号总数!
   比如:(()())
   第一个右括号只包含自己,故为 1;
   第二个右括号也只包含自己, 故为 1;
   第三个右括号包含前面两个括号,再加上自己,故为 3.
   所以应输出:1 1 3 ;
*/
第一组就是(((()()())))这样
输出是怎么出来的呢,那就是从左数第一个右括号,然后找到对应的左括号看看这对括号里面有几个括号(加上他们自己)
我是先用一个数组a[]来存数据,然后将a[]转化成括弧形式1代表左括弧0代表右括弧(b[])然后就是答案c[]
我的思路(从b[]到c[])是先找到第一个没有用过的右括弧,然后找左边离他最近的没被用过的左括弧,以此类推

#include <stdio.h>
#include <string.h>
#include<iostream>
#include <algorithm>
#include <stack>
using namespace std;
int a[10002];
int b[10002];
int c[10002];
int main()
{
    int i,j,n,m;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        a[0] = 0;                             //这样方便因为可以直接用后一个见前一个观察要输出几个1;
        for(i = 1;i <= n; i++)
        {
            scanf("%d",&a[i]);
        }
        i = 1;
        j = 0;
        while(i <= n)                 //a[]转b[]
        {
            int e = a[i]-a[i-1];
            while(e--)
            {
                b[j++] = 1;
            }
            b[j++] = 0;
            i++;
        }
        int e = 0;
        i = 0;
        bool vis[10002];
        memset(vis,0,sizeof(vis));
        while(i < j)
        {
            while(b[i] == 1&&i < j)             //找到右括弧
            {
                i++;
            }
            for(int w = i-1;w >= 0; w--)        //找到第一个没被用过的左括弧
            {
                if(b[w] == 1&&vis[w] == 0)
                {
                    c[e++] = (1+i-w)/2;          //括弧数
                    vis[w] = 1;
                    break;
                }
            }
            i++;
        }
        for(i = 0;i < e; i++)
        {
            printf(i != e-1?"%d ":"%d\n",c[i]);   //输出
        }
    }
}


代码菜鸟,如有错误,请多包涵!!!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值