A + B Problem II 大数相加(可以作为模板题)


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 317574    Accepted Submission(s): 61700


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

#include <stdio.h>
#include <string.h>
#define MAX 1005
using namespace std;

int a[MAX], b[MAX];
int sum[MAX];

void init ()
{
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    memset(sum, 0, sizeof(sum));
}

int bigNumAdd ( char ca[], char cb[] )
{
    int i;
    int len_ca = strlen(ca);
    int len_cb = strlen(cb);

    /*进制数值*/
    int carry = 0;

    /*将数值进行整数化,然后再进行反转*/
    for ( i = 0;i < len_ca; i++ )
    {
        a[i] = ca[len_ca-i-1]-'0';
    }
    for ( i = 0;i < len_cb; i++ )
    {
        b[i] = cb[len_cb-i-1]-'0';
    }

    /*找到最长的数值的长度*/
    int len_result = (len_ca > len_cb ? len_ca : len_cb);

    /*代码中最重要的部分*/
    for ( i = 0;i < len_result; i++ )
    {
        sum[i] = (a[i]+b[i]+carry)%10;
        carry = (a[i]+b[i]+carry)/10;
    }

    /*如果最后进制不为0*/
    if ( carry )
    {
        sum[i] = carry;
        len_result++;
    }

    /*返回和数的长度*/
    return len_result;
}

void NormalNum( char c[] )
{
    int i, j;
    int len = strlen(c);
    i = 0;
    while ( c[i] == '0'&&i != len-1 )
    {
        i++;
    }
    j = 0;
    while ( i <= len )
    {
        c[j++] = c[i++];
    }
}

int main()
{
    int t;
    int i, j;
    char ca[MAX], cb[MAX];

    scanf ( "%d", &t );
    for ( i = 1;i <= t; i++ )
    {
        /*初始化*/
        init();

        scanf ( "%s %s", ca, cb );

        /*数值的规范化,本题这步可以忽略*/
        NormalNum (ca);
        NormalNum (cb);

        int len_result = bigNumAdd (ca, cb);
        printf ( "Case %d:\n%s + %s = ", i, ca, cb );

        for ( j = len_result-1;j >= 0; j-- )
        {
            printf ( "%d", sum[j] );
        }
        printf ( "\n" );

        if ( i != t)
            printf ( "\n" );
    }
    return 0;
}

简化的代码(就简化了一点)
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define MAX 1005
using namespace std;

char ca[MAX], cb[MAX];
int a[MAX], b[MAX];
int sum[MAX];
int Max;

void init ()
{
    int i;
    int len_ca = strlen(ca);
    int len_cb = strlen(cb);
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    memset(sum, 0, sizeof(sum));
    Max = max(len_ca, len_cb)+2;
    for ( i = 0;i < len_ca; i++ )
    {
        a[i] = ca[len_ca-i-1]-'0';
    }
    for ( i = 0;i < len_cb; i++ )
    {
        b[i] = cb[len_cb-i-1]-'0';
    }
}

void bigNumAdd ()
{
    int i;
    int carry = 0;
    for ( i = 0; i < Max; i++ )
    {
        sum[i] = (a[i]+b[i]+carry)%10;
        carry = (a[i]+b[i]+carry)/10;
    }
}

int main()
{
    int t;
    int i, j;
    scanf ( "%d", &t );
    for ( j = 1;j <= t; j++ )
    {
        scanf ( "%s %s", ca, cb );
        init();
        bigNumAdd();
        printf ( "Case %d:\n%s + %s = ", j, ca, cb );
        for ( i = Max; i >= 0; i-- )
        {
            if(sum[i] != 0)
                break;
        }
        for ( i;i >= 0; i-- )
        {
            printf ( "%d", sum[i] );
        }
        printf ( "\n" );
        if ( j!= t)
        {
            printf ( "\n" );
        }
    }
    return 0;
}


代码菜鸟,如有错误,请多包涵!!!

如果有帮助记得鼓励我一下,谢谢!!!



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值