最小生成树问题 poj Building a Space Station

我今天要讲的是最小生成树的问题,其中我认为最好懂也是写起来很方便的一个算法了。它叫Kruskal算法。

在介绍算法之前呢我希望读者要学习会“并查集”这个东东,


那如何辨别有无连通成环呢?这就要用到并查集了!

大家可以搜一下并查集的代码和工作原理。

我贴上一个并查集的题吧!

大家快来A水题

Time Limit: 1000MS Memory limit: 65536K

题目描述

(1<= N <=2000) (1<= M <= N*(N-1)/2) 多组输入。每组第一行输入N,M。接下来M行每行,每行两个整数u,v代表岛u与v之间有一条路。

输出

 <span 宋体;="" font-size:="" 14px;="" text-align:="" justify;\"="" style="padding: 0px; margin: 0px;">每组数据输出一个整数,代表部落数。

示例输入

3 1
1 2
3 2
1 2
1 3

示例输出

2
1

提示

 

来源


代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAX_N 2050
int a[MAX_N];
int find(int x)
{
    int i,j,r;
    r = x;
    while(r != a[r])
    {
        r = a[r];
    }
    i = x;
    while(i != r)
    {
        j = a[i];
        a[i] = r;
        i = j;
    }
    return r;
}
void merge(int x,int y)
{
    int fx,fy;
    fx = find(x);
    fy = find(y);
    if(fx != fy)
    {
        a[fx] = fy;
    }
}
int main()
{
    int n,m,i;
    int x,y;
    while(~scanf("%d %d",&n,&m))
    {
        for(i = 1; i <= n; i++)
        {
            a[i] = i;
        }
        for(i = 1; i <= m; i++)
        {
            scanf("%d %d",&x,&y);
            merge(x,y);
        }
        int count = 0;
        for(i = 1; i <= n; i++)
        {
            if(a[i] == i)
            {
                count++;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}


然后就是算法的实现与测试了,看看下面的题:


Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7810 Accepted: 3775

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

Source

题目给出三维坐标系上的一些球的球心坐标和其半径,搭建通路,使得他们能够相互连通。如果两个球有重叠的部分则算为已连通,无需再搭桥。
代码实现:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
using namespace std;

int n, m;
int book[105];
struct node
{
    double x, y, z;
    double r;
}a[105];
struct node1
{
    double d;
    int u, v;
}b[10005];

bool cmp( node1 p, node1 q )
{
    return p.d < q.d;
}

void init()
{
    int i;
    for ( i = 0;i < n; i++ )
    {
        book[i] = i;
    }
}

double between( double x,double y, double z, double r, double x1, double y1, double z1, double r1 )
{
    double sum = sqrt(pow(x-x1, 2)+pow(y-y1, 2)+pow(z-z1, 2));
    double sum1 = r1+r;
    double sum2 = sum-sum1;
    if ( sum2 <= 0 )
        return 0;
    else
        return sum2;
}

int find(int x)
{
    while ( x != book[x] )
    {
        x = book[x];
    }
    return x;
}

int meget(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if ( fx != fy )
    {
        book[fx] = fy;
        return 1;
    }
    return 0;
}

double minDistance()
{
    init();
    int i, ant = 0;
    double sum = 0;
    sort(b, b+m, cmp);
    for ( i = 0;i < m; i++ )
    {
        if ( ant == n-1 )
            break;
        if ( meget(b[i].u, b[i].v) )
        {
            sum = sum+b[i].d;
            ant++;
        }
    }
    return sum;
}

int main()
{
    int i, j;
    while ( ~scanf ( "%d", &n )&& n != 0 )
    {
        int k = 0;
        for ( i = 0; i < n; i++ )
        {
            scanf ( "%lf %lf %lf %lf", &a[i].x, &a[i].y, &a[i].z, &a[i].r );
            for ( j = 0;j < i; j++ )
            {
                b[k].u = i;
                b[k].v = j;
                b[k++].d = between(a[i].x, a[i].y, a[i].z, a[i].r, a[j].x, a[j].y, a[j].z, a[j].r );
            }
        }
        m = k;
        double sum = minDistance();
        printf ( "%.3f\n", sum );
    }
    return 0;
}

代码菜鸟,如有错误,请多包涵!!!
如果有帮助记得支持我一下,谢谢!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值