Pie

Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15662 Accepted: 5355 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655
/*

就是公平地分披萨pie

我生日,买了n个pie,找来f个朋友,那么总人数共f+1人

每个pie都是高为1的圆柱体,输入这n个pie的每一个尺寸(半径),如果要公平地把pie分给每一个人(就是所有人得到的pie尺寸一致,但是形状可以不同),而且每个人得到的那份pie必须是从同一个pie上得到的

后面那句很重要,

就是说如果有3个pie, 尺寸分别为1,2,3,

如果要给每人尺寸为2的pie,那么最多分给2个人,而不是3个人

因为第一个pie尺寸为1,小于2,扔掉

第二个pie尺寸为2,等于2,刚好分给一个人

第三个pie尺寸为3,切出尺寸为2的一份,分给一个人,剩下的尺寸为1的就扔掉

*/
这个题就用二分做就可以了,我以前还想这用优先队列呢?!
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <iostream>
#define M 3.14159265359
#define N 1e-7
using namespace std;

double v[10005];

int main()
{
    int n, m, i;
    int T;
    double h;
    scanf ( "%d", &T );
    while ( T-- )
    {
        scanf ( "%d %d", &n, &m );
        m++;
        double low = 0, high = 0;
        for ( i = 0;i < n; i++ )
        {
            scanf ( "%lf", &h );
            v[i] = h*h;
            if ( high < v[i] )
                high = v[i];
        }
        double mid;
        while ( high-low >= N )
        {
            mid = (high+low)/2;
            int max1 = 0;
            for ( i = 0;i < n; i++ )
            {
                if ( v[i]-mid >= N )
                {
                    max1 = (int)(v[i]/mid)+max1;
                }
            }
            if ( max1 >= m )
                low = mid;
            else
                high = mid;
        }
        printf ( "%.4f\n", mid*M );
    }
}

代码菜鸟,如有错误,请多包涵!
如有帮助记得支持我一下,谢谢!!!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值