To Fill or Not to Fill

                 题目1437:To Fill or Not to Fill

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:3577

解决:814

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入:

For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

输出:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
50 1300 12 2
7.10 0
7.00 600
样例输出:
749.17
The maximum travel distance = 1200.00
来源:
2012年浙江大学计算机及软件工程研究生机试真题
贪心算法。调BUG俩小时发现是精度问题!以后带小数点的测试数据,老老实实全用浮点型吧。。。。
import java.util.*;

public class ToFillOrNotToFill {
	static private Scanner input;
	static int Cmax, D, Davg, N;
	/*
	 * 九度oj1437 Cmax (<= 100), the maximum capacity of the tank; D (<=30000),
	 * the distance between Hangzhou and the destination city; Davg (<=20), the
	 * average distance per unit gas that the car can run; and N (<= 500), the
	 * total number of gas stations.
	 */
	private static final int INF = 1 << 30;
	static int next; // 下一个要走的“贪心”位置
	static Station[] s;

	public static void main(String[] args) {
		input = new Scanner(System.in);
		s = new Station[502];
		for (int i = 0; i < 502; i++)
			s[i] = new Station(0, 0);
		while (input.hasNext()) {
			Cmax = input.nextInt();
			D = input.nextInt();
			Davg = input.nextInt();
			N = input.nextInt();
			for (int i = 0; i < N; i++) {
				float price = input.nextFloat();
				float distance = input.nextFloat();
				s[i].price = price;
				s[i].distance = distance;
			}
			Arrays.sort(s, 0, N); // 按照距离从小到大排序
			
			/* for( int i = 0 ; i < N ; i++ ) 
				 System.out.println(s[i].price+"  "+ s[i].distance);*/
			 
			int maxDis = Cmax * Davg; // 最大可走距离
			float totalCost = 0; // 花钱总数
			float dis = 0; // 总共已行走的距离
			float leftO = 0; // 剩余的油
			int i = 0;
			if (s[0].distance != 0 || N == 0) {
				System.out.println("The maximum travel distance = 0.00");
				continue;
			}
			while (true) {
//				System.out.println("当前的站点:"+i+"当前使用金钱:"+totalCost+"当前剩余油量:"+leftO);
				float minPrice = findMin(i, maxDis);
				
				if (minPrice == INF) {	//当前站是最后一站
					if (s[i].distance + maxDis >= D) {
						totalCost += ((D - s[i].distance) / Davg - leftO)*1.0 * s[i].price;
						System.out.printf("%.2f\n", totalCost);
						break;
					} else {
						dis = s[i].distance + maxDis;
						System.out.printf("The maximum travel distance = %.2f\n", dis);
						break;
					}
				} else if (minPrice >= s[i].price) { // 当前站是可达范围内最便宜的站
					if (s[i].distance + maxDis >= D) {	//当前位置可以直达终点站
						float needO = (float) ((D - s[i].distance)*1.0 / Davg);
						if (needO <= leftO) {
							System.out.printf("%.2f\n", totalCost);
						} else {
							totalCost += (needO - leftO)* 1.0 * s[i].price;
							System.out.printf("%.2f\n", totalCost);
						}
						break;
					} else {	//当前位置不能到达终点站,在最便宜的站加满油
						totalCost += (Cmax - leftO) * s[i].price;
						leftO = (float) (Cmax - ((s[next].distance - s[i].distance)*1.0 / Davg));
						i = next;
					}
				} else { // 可达范围内有更便宜的站
					totalCost += ((s[next].distance - s[i].distance)*1.0 / Davg - leftO) * s[i].price;
					/*System.out.println("s[i].distance:"+s[i].distance);
					System.out.println("s[next].distance:"+s[next].distance);
					System.out.println(totalCost+"---"+s[next].distance+"$:"+s[i].price);*/
					leftO = 0;
					i = next;
				}
//				System.out.println(i);
			}
		}
	}

	private static float findMin(int i, double range) {
		// TODO Auto-generated method stub
		float maxDis = (float) (s[i].distance + range);
		float minPrice = INF;
		for (int j = i + 1; j < N; j++) {
			if (s[j].distance <= maxDis && s[j].distance < D) { // 既在可达范围内,又在终点前
				if (s[j].price <= minPrice) { // 更贵则选择最便宜的
					minPrice = s[j].price;
					next = j;
				}
				if (minPrice < s[i].price) // 若更便宜则选择最近的一个
					break;
			} else { // 超出范围
				break;
			}
		}
		return minPrice;
	}
}

class Station implements Comparable<Station> {
	float price;
	float distance;

	public Station(float price, float distance) {
		this.distance = distance;
		this.price = price;
	}

	@Override
	public int compareTo(Station o) {
		// TODO Auto-generated method stub
		if (this.distance > o.distance) {
			return 1;
		} else if (this.distance == o.distance) {
			return 0;
		} else {
			return -1;
		}
	}
}

来源:http://ac.jobdu.com/problem.php?pid=1437

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值