HDU 1171 Big Event in HDU by Assassin

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).


Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.


Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.


Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1



Sample Output

20 10
40 40

思路:
简单的多重背包,用一个数组a[]纪录所有选择的情况,注意一下这里需要dp[i]表示选择或不选择第i中情况,如果一般情况一一列举o(n^2)会成5000*5000,感觉不会过了,所以做一下二值化
什么是二值化比如 13=1+2+4+6其他13内的任何数都可以用他们1 2 4 6表示,这就大大减少了维度。多重背包不懂的请百度一下学习一下吧~

#include<bits/stdc++.h>
#define input freopen("input.txt","r",stdin)
using namespace std;
int dp[1000],a[1000];
int value,num,bol,tmp,sum,maxx; 
int main()
{
    input;
    int n,i,j;
    while(cin>>n)
    {
        if(n<0)break;
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        tmp=1;
        sum=0;
        for(i=1;i<=n;i++)
        {
            cin>>value>>num;
            sum+=value*num;
            bol=1;
            while(1)
            {
                if(num>=bol)
                {
                    a[tmp++]=value*bol;
                    num-=bol;
                    bol<<=1;
                }
                else if(num>0&&num<bol)
                {
                    a[tmp++]=value*num;
                    break;
                }
                if(num<=0)break;
            }
        }
        for(i=1;i<tmp;i++)
        {
            for(j=0;j<i;j++)
            {
                if(dp[i]<dp[j]+a[i]&&dp[j]+a[i]<=sum/2)
                {
                    dp[i]=dp[j]+a[i];
                }
            }
        }
        for(maxx=0,i=1;i<tmp;i++)
        {
            if(maxx<dp[i])
            {
                maxx=dp[i];
            }
        }
        cout<<sum-maxx<<" "<<maxx<<endl;//注意要第一个大于第二个
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值