HDU 3347 Calculate the expression By Assassin 模拟水题

题目大意

You may find it’s easy to calculate the expression such as: 
a = 3 
b = 4 
c = 5 
a + b + c = ? 
Isn’t it? 

Input

The first line contains an integer stands for the number of test cases.
    Each test case start with an integer n stands for n expressions will follow for this case.
Then n – 1 expressions in the format: [variable name][space][=][space][integer] will follow.
You may suppose the variable name will only contain lowercase letters and the length will not exceed 20, and the integer will between -65536 and 65536.
The last line will contain the expression you need to work out.
In the format: [variable name| integer][space][+|-][space][variable name| integer] …= ?
You may suppose the variable name must have been defined in the n – 1 expression and the integer is also between -65536 and 65536. 
You can get more information from the sample.

Output

For each case, output the result of the last expression.

Sample Input

3
4
aa = 1
bb = -1
aa = 2
aa + bb + 11 = ?
1
1 + 1 = ?
1
1 + -1 = ?

Sample Output

12
2
0

题目分析

乍一看挺难,但是注意看题!!!前n-1行格式是固定的,一定是给变量赋值,最后一行就是变量+常数的加减,比较简单,注意每次考虑运算的符号即可。变量可以用 map记录

(开始把题目想太复杂了,所以记录一下简单的做法)

#include<bits/stdc++.h>
using namespace std;
map<string,int>mp;
int string_to_int(string s){        //字符串 
    int sum=0,pos=0,sign=0;
    if(s[pos]=='-'){
        sign=1;
        pos++;
    }
    for(;pos<s.size();pos++){
        sum=sum*10+s[pos]-'0';
    }
    if(sign==1){
        return -sum;
    }
    else {
        return sum;
    }
}
int main(){
    int t,n;
    string variablename,c,integer;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        mp.clear();
        for(int i=1;i<n;i++){
            cin>>variablename>>c>>integer;
            mp[variablename]=string_to_int(integer);
        }
        int sign=0;
        long long ans=0;
        while(cin>>c){
            if(c.size()==1){
                if(c[0]=='-'){
                    sign=1;
                    continue;
                }
                else if(c[0]=='+'){
                    sign=0;
                    continue;
                }
            }
            if(c[0]=='=')continue;
            if(c[0]=='?')break;
            if(c[0]>='a'&&c[0]<='z'){
                if(sign==1){
                    ans-=mp[c];
                }
                else {
                    ans+=mp[c];
                }
            } 
            else {
                if(sign==1){
                    ans-=string_to_int(c);
                }
                else {
                    ans+=string_to_int(c);
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0; 
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值