POJ-3096

Surprising Strings

Time Limit: 1000MSmemory Limit: 65536K

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.


题目大意:
给定一个字符串,如果这个字符串按照间隔 d 取字符对的过程中,对于相同的d没有相同字符对是相同的。 那么这个字符串就是 d-unique的。
而如果这个字符串对于每一个di都是 di-unqiue的话,这个字符串就满足surprising的。
现在给你几个字符串,请你依次判断他们是不是surprising的。
解题思路:
首先如果字符串长度小于等于2的话,显然是满足的。只有长度超过了2,例如”AAA”,它就是不满足1-unique的,所以不是surprising的。但是它是2-unqiue的,因为它只有一个2-pairs的字符对“AA”。从中,我们也就知道,对于一个长度为n(n>2)的字符串,如果验证了3,4,… ,n-1 unique都满足的话就认为它是surprising的了。
小技巧
对于每一个字符对,可以将它记录为一个数。由于题目中确认输入中只包含大写字母,那么就可以把这个字符对看成一个两位数。
x = int(arr[j] - 'A') * 26 + int(arr[j + i] - 'A');
另外注意只要中间发现一个不满足,是可以跳出多层循环的。


源代码

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;

char  arr[80];
int num;
int main() {
    int i, j,k,x,y;
    bool flag;
    scanf("%s", arr);
    while (arr[0] != '*') {
        flag = true;
        num = strlen(arr);
        if (num >2) {
            for (i = 1; i < num && flag; i++) {
                for (j = 0; j < num - i-1 && flag; j++) {
                    x = int(arr[j] - 'A') * 26 + int(arr[j + i] - 'A');
                    for (k = 1; k < num - j - i; k++) {
                        y = int(arr[j + k] - 'A') * 26 + int(arr[j + k + i] - 'A');
                        if (x == y) {
                            flag = false;
                            break;
                        }
                    }

                }
            }
        }
        if (flag) {
            printf("%s is surprising.\n",arr);
        }
        else {
            printf("%s is NOT surprising.\n", arr);
        }
        scanf("%s", arr);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值