浙大数据结构:10-排序5 PAT Judge (25 分)

10-排序5 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

代码

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#pragma warning(disable: 4996)  
using namespace std;
#define Maxsize 10001
typedef struct UserNode{
	int rank;//总分相同的排名一样
	int id;
	int p[5];
	int Perfect;
	int Sum;
	int flag;//不是所有的用户都会有过提交,未参与的不参与排序,因此要有个flag
	UserNode() :rank(0),id(0), Perfect(0), Sum(0), flag(0) {
		for (int i = 0; i < 5; i++) {
			p[i] = -2;//提交了没有编译通过的话输出0,没有提交过为-,提交了0分还是0,这个-2在输出的时候有用
		}
	}

}Users[Maxsize];

bool cmp(UserNode& u1,UserNode& u2) {
	if (u1.flag != u2.flag)
		return u1.flag > u2.flag;
	else if (u1.Sum != u2.Sum)
		return u1.Sum > u2.Sum;
	else if (u1.Perfect != u2.Perfect)
		return u1.Perfect > u2.Perfect;
	else if (u1.id != u2.id)
		return u1.id < u2.id;
};


int main()
{
	Users U;
	int N, K, M;
	cin >> N >> K >> M;
	int Pmax[5];
	for (int i = 0; i < K; i++) {
		cin >> Pmax[i];
	}
	for (int i = 0; i <= N; i++) {
		U[i].id = i;
	}
	/*输入信息*/
	int id, pro_id, pro_score;
	for (int i = 0; i < M; i++) {
		cin >> id >> pro_id >> pro_score;
		if (U[id].p[pro_id-1]<pro_score) {
			if (pro_score >= 0)U[id].p[pro_id - 1] = pro_score;
			if (pro_score == -1)U[id].p[pro_id - 1] = 0;
		}
	}
	int TotalPerson = 0;
	/*统计信息perfect,sum,flag,参与排名总人数*/
	for (int i = 1; i <= N; i++) {
		/*perfect*/
		for (int j = 0; j < K; j++) {
			if (U[i].p[j] == Pmax[j]) {
				U[i].Perfect++;
			}
		}
		/*Sum*/
		for (int j = 0; j < K; j++) {
			if (U[i].p[j] >= 0) {
				U[i].Sum = U[i].Sum + U[i].p[j];
				if (U[i].Sum>0) {
					U[i].flag = 1;//有分的才参与排名,编译没有通过,或者没分的不排名
				}
			}
		}
		if (U[i].flag == 1)TotalPerson++;
	}
	sort(U + 1, U + N + 1, cmp);
	/*调整rank*/
	U[1].rank = 1;
	for (int i = 2; i <= N; i++) {
		if (U[i].Sum == U[i - 1].Sum) {
			U[i].rank = U[i - 1].rank;
		}
		else
			U[i].rank = i;
	}
	if (TotalPerson == 0)TotalPerson = 1;//至少输出一个人
	for (int i = 1; i <=TotalPerson; i++) {
		printf("%d %05d %d", U[i].rank, U[i].id, U[i].Sum);
		for (int j = 0; j < K; j++) {
			if (U[i].p[j] >= 0)cout << " " << U[i].p[j];
			else if (U[i].p[j] == -2)cout << " -";
		}
		cout << endl;
	}

	return 0;
}

测试结果

在这里插入图片描述

总结

这道题说实在我是服气的,说考数据结构吧,那确实考察了用户结构里面应该设置哪些变量,难也不是很难。但是本身细节极多,说几个要注意的点:

1.总分相同,排名要相同,即排名是1 2 2 2 5,不是1 2 2 2 3,也不是强硬的1 2 3 4 5,这个输出要进行调整,所以加入了rank变量。

2.并非所有N个用户都参加,因此在提交的时候要记录用户是否参加,没有参加的用户不参与排名,因此加入了flag变量

3.输出的顺序和总分,完全完成数目,id有关,因此加入了Sum,perfect两个变量

4.基本变量id,p[5],不再赘述,在读入成绩的时候也要特殊处理,在输出的时候要判断是否提交过

5.排序部分反而弱化了,直接用sort()来完成,但是sort要求自己写一个比较函数,也算是一个知识点。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值