浙大数据结构:10-排序6 Sort with Swap(0, i) (25 分)

10-排序6 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (≤10​5​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9

代码

#include<iostream>
#define Maxsize 100000
int A[Maxsize];
using namespace std;

int CountLoop(int a[], int i,int N) {
	/*计算a[]的第i个元素的环*/
	int flag = 0;//环里面是否含有0
	int NextIndex, CurIndex;
	int count = 0;//count统计点的个数
	CurIndex = i;
	if (a[CurIndex] == CurIndex)return 0;
	while (a[CurIndex] != CurIndex) {
		if (a[CurIndex] == 0)flag = 1;
		NextIndex = a[CurIndex];
		a[CurIndex] = CurIndex;
		CurIndex = NextIndex;
		count++;
	}
	if (flag == 1)return count-1;
	if (flag == 0)return count+1;

}

int TimesOfSwap(int a[], int N) {
	int res = 0;
	for (int i = 0; i < N; i++) {
		res += CountLoop(a, i,N);
	}
	return res;
}

int main() {
	int N;
	cin >> N;
	for (int i = 0; i < N; i++) {
		cin >> A[i];
	}
	cout << TimesOfSwap(A, N);
	return 0;
}

测试结果

在这里插入图片描述

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值