hdu 1025 Cstructing Roads (Constructing Roads In JGShining's Kingdom)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1025

 

题目描述:

 

Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

For example, the roads in Figure I are forbidden. 



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 

Output

For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

 

 

 

题目大意:

输入n组数据,每组数据两个整数a和b相连,a在l1路,b在l2路,要求任何两条路之间不想交,问最多能建多少条路

 

题目分析:

这题类似于免费馅饼那一题,可以把条件转化一下,把a作为维度b作为值即v[a]=b或者把b作为维度a作为值(v[b]=a),然后求一下最长上身子序列即可,输出长度

由于数据量比较大,这里需要用二分法解决

 

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<cmath>
using namespace std;

int dp[50005],v[50005];

int main()
{
    int n,p,r,top,left,right,mid,num=1;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&p,&r);
            v[p]=r;
        }
        dp[1]=v[1];
        top=1;
        for(int i=2;i<=n;i++)
        {
            if(v[i]>dp[top])//如果比栈顶元素大,压入栈
            {
                dp[++top]=v[i];
            }
            else//否则,利用二分法查找,用该元素替换比他大的第一个元素到栈
            {
                left=1;
                right=top;
                while(left<=right)
                {
                    mid=(left+right)/2;
                    if(v[i]>dp[mid])
                        left=mid+1;
                    else
                        right=mid-1;
                }
                dp[left]=v[i];
            }
        }
        if(top==1)
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",num++,top);
        else
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",num++,top);
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值