poj 1979 Red and Black

题目链接:http://poj.org/problem?id=1979

题目:

 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 

 

题目大意:

找出与@在同一个联通块的‘.’的数目

题目分析:

DFS(强烈推荐变量名要用常规的。。因为x_少写了一个下划线找了好久的bug)

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int sx,sy;
int m,n;
int sum;
const int maxn=25;
char map[maxn][maxn];
int dx[]={0,0,-1,1};
int dy[]={1,-1,0,0};
void dfs(int x,int y)
{
    for(int i=0;i<4;i++)
    {
        int x_=x+dx[i],y_=y+dy[i];
        if(x_>=0&&x_<n&&y_>=0&&y_<m)
        {
            if(map[x_][y_]=='.')
            {
                sum++;
                map[x_][y_]='#';
                dfs(x_,y_);
            }
        }
    }
    return ;
}
int main()
{
    while(scanf("%d%d",&m,&n))
    {
        if(!(m||n))
            break;
        bool sign=false;
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            if(!sign)
            {
            for(int j=0;j<m;j++)
            {
                if(map[i][j]=='@')
                {
                    sx=i;
                    sy=j;
                    sign=true;
                    break;
                }
            }
            }
        }
        sum=1;
        map[sx][sy]='#';
        dfs(sx,sy);
        cout<<sum<<endl;
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值