DP-前n个数的最大升序子段和问题-HDU1087

Super Jumping! Jumping! Jumping!

  HDU - 1087 
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 
InputInput contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
OutputFor each case, print the maximum according to rules, and one line one case. 
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

题目大意是一个小球从左往右跳,最少跳一个,最多不限,但只能跳到比现在更大的位置,初始位置看做最小。

前n个数的最大升序子段和问题,但是我一开始读完题之后觉得一个回溯法就ok了,结果超时了...后来估算了一下回溯的时间复杂度,2^1000,不超时才怪,所以需要一个记忆化的数组来保存前i次的最大和。

定义dp[i]为前i个数的最大子段和,这样以后每次比的时候只需要  max( dp[j] , temp ),temp为当前值,如果前i-1个中没有小于a[i]的,那么temp=0;

ok,代码贴上 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;
int n,a[1005],Max;
int dp[1005];//dp[i]为前i个数的最大升序子段和
const int inf=99999;
int main()
{
    int i,j;
	while(cin>>n && n)
	{
	    int temp;
		for(i=1;i<=n;i++)
            cin>>a[i];
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++){
            temp=-inf;
            for(j=0;j<i;j++){
                if(a[j]<a[i])
                    temp=max(temp,dp[j]);//如果i前没有小于它的,temp就为0
            }                           //且dp[i]也为它本身
            dp[i]=temp+a[i];
        }
        temp=-inf;
        for(i=1;i<=n;i++)
            if(dp[i]>temp)
                temp=dp[i];
        cout<<temp<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值