[PYTHON](PAT)1016 PHONE BILLS (25)

43 篇文章 0 订阅

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

 

题目大意

给定电话公司每个小时的话费收费标准以及一些通话记录,要求按照实例输出的格式输出电话账单。

按照时间顺序,每一个接通都要对应一个挂断,如果一个接通后面又是一个接通,则第一个接通舍弃。以此类推舍弃挂断的情况。

要注意有一个测试点会有先给挂断的情况,所以要检测,第一个是否是接通,然后再找匹配的挂断。

分析

有一个难点是计算通话的花费,参考了大神的方法:

假设接通时间为A,挂断时间为B。计算从00:00:00到A的话费 T1,计算从00:00:00到B的话费T2,最终的话费就是T2-T1,直接避免了各种繁琐的计算和跨天计算的烦恼。

首先将客户姓名按照升序排序,读取他们存储在字典中的通话记录情况,按照时间顺序排序通话记录,剔除不符合条件的通话记录后,每对作为一个元素存储入bill数组。

读取每一个元素,进行计算话费,注意,最后再进行美分转美元,不然可能得不出答案要的数字。

Python实现

def main():
    line = input().split(" ")
    rate = [int(x) for x in line]
    oneday = sum([x for x in rate])*60
    num = int(input())
    record = {}
    for x in range(num):
        line = input().split(" ")
        if line[0] in record:
            record[line[0]] .append(line[1:])
        else:
            record[line[0]] = [line[1:]]
    name = sorted(record.keys())
    for x in name:
        unit = sorted(record[x])
        bill = []
        stack = []
        for i in unit:
            if len(stack) == 0:
                if i[1] =='on-line':
                    stack.append(i)
            else:
                if i[1] == stack[0][1]:
                    stack[0] = i
                else:
                    bill.append([stack[0],i])
                    stack = []
        if len(bill) >0 :
            count = 0
            result = '{} {}\n'.format(x, bill[0][0][0][:2])
            for i in bill:
                start = i[0][0]
                end = i[1][0]
                result = result + start[3:] + ' '+ end[3:] + ' '
                m1, m2=0, 0
                day1, day2= int(start[3:5]), int(end[3:5])
                hour1, hour2 = int(start[6:8]), int(end[6:8])
                minute1, minute2 = int(start[9:11]), int(end[9:11])
                m1 = oneday * day1 + sum(rate[:hour1])*60 + rate[hour1]*int(minute1)
                m2 = oneday * day2 + sum(rate[:hour2])*60 + rate[hour2]*int(minute2)
                time = (day2 - day1)*24*60 + (hour2-hour1)*60 + minute2 - minute1
                result = result + str(time)+' '
                m = m2 - m1
                result = result+'$'+'{:.2f}'.format(m/100)+'\n'
                count += m
            result = result+'Total amount: ${:.2f}'.format(count/100)
            print(result)
            
if __name__ == "__main__":
    main()

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值