[Python](PAT)1138 Postorder Traversal(25 分)

43 篇文章 0 订阅

用Python写PAT甲级,答案都在这里了

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

题目大意

给定一颗二叉树的前序遍历和中序遍历顺序,要求输出后序遍历的第一个节点

分析

每一个前序遍历的第一个节点都是这部分二叉树的根,在中序遍历中找到这个节点的位置,左边是左子树,右边是右子树。存在左子树的情况下,接下来去遍历左子树,按照前面的方法找到左子树的左右子树。如果没有左子树则去遍历右子树。

这样的方法可以用递归去写,也可以不用递归写。

但是倒数第二个测试点都会有问题。递归的话会内存超限,不递归会超时,o(︶︿︶)o

最后一个测试点也有问题,使用列表推导式转换前序和后续会非零返回,要套一层异常捕捉就好了,这是为什么???

Python实现

 

def dfs(pre,inorder):
    global flag
    if not flag:
        if len(pre) == 1:
            print(pre[0])
            flag = True
        root = pre[0]
        index = inorder.index(root)
        if index >0:
            inorder_first = inorder[:index]
            pre_first = pre[1:1+index]
            dfs(pre_first,inorder_first)
        else:
            inorder_second = inorder[index+1:]
            pre_second = pre[1+index:]
            dfs(pre_second,inorder_second)
    else:
        return
    
def main():
    input()
    line = input().split(" ")
    pre=[]
    for x in line:
        try:
            pre.append(int(x))
        except:
            break
    line = input().split(" ")
    inorder=[]
    for x in line:
        try:
            inorder.append(int(x))
        except:
            break
    dfs(pre,inorder)
    
if __name__ == "__main__":
    flag = False
    main()

更多技术干货,有趣文章,点这里就对了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值