[Python](PAT)1027 Colors in Mars(20 分)

43 篇文章 0 订阅

用python写PAT甲级,答案都在这

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题目大意

给定三个十进制整数,将它们转换成十三进制,合并字符串后在首位加上“#”输出。

分析

因为整数的范围是[0-168],所以十三进制下,不会超过两位。

用l表示13进制的数字列表

第一位数是第a // 13个数字

第二位是第a % 13个 数字

合并字符串之后输出

python实现

def change(num):
    l = '0123456789ABC'
    a = int(num)
    first, second = a // 13, a % 13
    return l[first] + l[second]

if __name__ == "__main__":
    line = input().split(" ")
    result = ''
    for x in line:
        result += change(x)
    print('#'+result)

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值