(HDU)2846 - Repository 【字典树变形】

Repository

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                  Total Submission(s): 1129    Accepted Submission(s): 382


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s
 

Sample Output
0
20
11
11
2
 
根据题意可知:题目属于判断字符串中是否包含子串的问题,对于一般的字典树,用来判断前缀,而这里不能直接这么去建树。在建树的时候将字符串X=X1X2....Xn的分别以X1,X2....Xn开头的后缀子串插入到Trie树中,如此一来就可以判断某个字符串是否被包含在另一个字符串当中。但是这就有一个问题,比如插入了字符串abab,那么当查找字符串ab时就会重复计数,因此需要多设计一个标识以表示在插入"abab"和"ab"时时同一个字符串即可(是同一个字符串就不需要使计数器加1),因此在Trie树结点中多设计一个商品id来标记。id用来记录最后一个经过此路径上的商品编号,如果要插入的字符串编号同当前节点的编号不同,则计数器加1,并且将当前结点的编号置为要插入的字符串的编号。


#include <iostream>
#include<cstring> 
#define MAX 26
using namespace std;

typedef struct Trie_Node
{
    int count;                  //记录包含该结点的单词个数 
     int id;                     //最后一次经过此结点的商品ID 
    Trie_Node *next[MAX];
}Trie;

void insert(Trie *root,char *s,int id)
{
    Trie *p=root;
    while(*s!='\0')
    {
        if(p->next[*s-'a']==NULL)
        {
            Trie *temp=(Trie *)malloc(sizeof(Trie));
            for(int i=0;i<MAX;i++)
            {
                temp->next[i]=NULL;
            }
            temp->count=0;
            temp->id=-1;            //-1表示没有商品 
            p->next[*s-'a']=temp;
        }
        p=p->next[*s-'a'];
        if(p->id!=id)             //如果当前结点的商品ID不等于要插入商品的ID,则计数器count++,并且重新置ID的值 
         {
            p->id=id;
            p->count++;
        }
        s++;
    }
}


int search(Trie *root,char *s)
{
    Trie *p=root;
    for(int i=0;s[i]!='\0';i++)
    {
        if(p->next[s[i]-'a']==NULL)
            return 0;
        p=p->next[s[i]-'a'];
    }    
    return p->count;
}

int main(int argc, char *argv[])
{
    int i,j;
    int n,m;
    char s[21];
    Trie *root=(Trie *)malloc(sizeof(Trie));
    for(i=0;i<MAX;i++)
    {
        root->next[i]=NULL;
    }
    root->count=0;
    root->id=-1;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%s",s);
        for(j=0;j<strlen(s);j++)       //将字符串X=X1X2...Xn的分别以X1,X2...Xn开头的后缀字符串插入到Trie树中 
         {
            insert(root,s+j,i);
        }    
    }
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%s",s);
        printf("%d\n",search(root,s));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值