PAT A1071. Speech Patterns (25)

原文链接: PAT A1071. Speech Patterns (25)

上一篇: PAT A1054. The Dominant Color (20)

下一篇: PAT A1022. Digital Library (30)

1071. Speech Patterns (25)

https://www.patest.cn/contests/pat-a-practise/1071

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

HOU, Qiming

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive .

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题目大意:统计单词个数~~大小写字母+数字的组合才是合法的单词,给出一个字符串,求出现的合法的单词的个数最多的那个单词,以及它出现的次数。如果有并列的,那么输出字典序里面的第一个~~~
分析:用map很简单的~不过呢~有几个注意点~~:
1. 大小写不区分,所以统计之前要先s[i] = tolower(s[i]);
2. [0-9 A-Z a-z]可以简写为cctype头文件里面的一个函数isalnum~~
3. 必须用getline读入一长串的带空格的字符串~~
4. 一定要当t不为空的时候m[t]++,因为t为空也会被统计的!!!~~~
5. 最最重要的是~~,如果最后一个字符是合法的,那么因为else是建立在遇到分隔符(即不合法字符)的前提下的,所以必须在for循环之外再判断一次if(t.length()) m[t]++;~~~要不然最后一个合法的单词可能会被忘记记入进去而导致最后一个测试点不通过~~~


#include <iostream>
#include <map>
#include <string>
#include <cctype>
using namespace std;
int main() {
    string s, t;
    getline(cin, s);
    map<string, int> m;
    for(int i = 0; i < s.length(); i++) {
        if(isalnum(s[i])) {
            s[i] = tolower(s[i]);
            t += s[i];
        } else {
            if(t.length())
                m[t]++;
            t = "";
        }
    }
    if(t.length()) m[t]++;
    int maxn = 0;
    for(map<string, int>::iterator it = m.begin(); it != m.end(); it++) {
        if(it->second > maxn) {
            maxn = it->second;
            t = it->first;
        }
    }
    cout << t << " " << maxn;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
manning.microservices.patterns是指微服务架构模式方面的内容。微服务是一种架构风格,它将一个应用程序拆分为一组小的、独立的服务,每个服务都可以独立部署、扩展和维护。manning.microservices.patterns通过提供一些常见的模式,帮助开发人员构建可靠、可伸缩、可维护的微服务架构。 首先,manning.microservices.patterns介绍了服务拆分的模式。它提供了一些指导原则,帮助开发人员确定应该将哪些功能拆分为独立的服务,以及如何定义服务边界。这样可以确保每个服务都专注于一个明确的业务领域,并且可以独立地开发和部署。 其次,manning.microservices.patterns讨论了服务间通信的模式。微服务架构中,各个服务需要相互通信来实现业务流程。这本书介绍了一些常见的通信模式,例如同步调用、异步消息传递和事件驱动架构。开发人员可以根据实际需求选择适合的通信方式。 此外,manning.microservices.patterns还介绍了服务发现和负载均衡的模式。由于微服务架构中的服务数量庞大,需要有一种方法来发现和跟踪可用的服务实例。这本书提供了一些模式,如服务注册与发现、负载均衡和断路器模式,帮助开发人员实现可靠的服务发现和负载均衡机制。 最后,manning.microservices.patterns还探讨了监控和故障处理的模式。微服务架构中,每个服务都可以独立部署和维护,因此需要一种方法来监控服务的健康状况,并及时处理故障。这本书介绍了一些常见的监控和故障处理模式,例如服务指标监控、日志聚合和异常处理模式。 总之,manning.microservices.patterns是一本关于微服务架构模式的书籍,它提供了一些常见的模式,帮助开发人员构建可靠、可伸缩、可维护的微服务架构。这些模式涵盖了服务拆分、服务间通信、服务发现和负载均衡、监控和故障处理等方面,可以帮助开发人员在构建微服务架构时更加高效地解决各种技术挑战。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值