PAT A1052. Linked List Sorting (25)

原文链接: PAT A1052. Linked List Sorting (25)

上一篇: PAT A1032. Sharing (25)

下一篇: PAT A1097. Deduplication on a Linked List (25)

1052. Linked List Sorting (25)

https://www.patest.cn/contests/pat-a-practise/1052

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:给出一个链表,将链表排序,然后把链表上的结点按照data值的从小到大顺序输出
分析:建立结构体数组,按照从首地址开始的顺序(直到-1)遍历一遍整个链表,将在链表中的结点的flag标记为true,并且统计count(有效结点的个数)。(因为有的结点根本不在链表中)
然后将链表进行排序,如果flag == false就把他们移动到后面(即:reuturn a.flag > b.flag),最后只输出前cnt个链表的信息~~~

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 111111;
struct Node {
	int address, data, next;
	bool flag;	//是否在链表上 
}nodes[MAX];
int cmp(const Node &a, const Node &b) {
	if (a.flag && b.flag)	//两个节点都是有效节点,按照要求排序
		return a.data < b.data;
	else
		return a.flag > b.flag;	//只要有一个是无效节点,就把它放到后面去 
}
int main(int argc, char *argv[]) {
	int n, first, address;
	scanf("%d%d", &n, &first);
	for (int i = 0; i < n; i++) {
		scanf("%d", &address);
		scanf("%d%d", &nodes[address].data, &nodes[address].next);
		nodes[address].address = address;
	}
	int count = 0;	//有效节点个数
					//遍历统计节点数目 
	for (int i = first; i != -1; i = nodes[i].next) {
		nodes[i].flag = 1;
		count++;
	}

	//没有有效节点时 
	if (count == 0) {
		printf("0 -1\n");
		return 0;
	}
	sort(nodes, nodes + MAX, cmp);
	printf("%d %05d\n", count, nodes[0].address);	//防止-1被格式化为%05d,提前判断
	for (int i = 0; i < count; i++) {
		if (i != count - 1) {
			printf("%05d %d %05d\n", nodes[i].address, nodes[i].data, nodes[i + 1].address);
		} else {
			printf("%05d %d -1\n", nodes[i].address, nodes[i].data);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值