PAT A1059. Prime Factors (25)

原文链接: PAT A1059. Prime Factors (25)

上一篇: PAT A1096. Consecutive Factors (20)

下一篇: PAT B1017. A除以B (20)

1059. Prime Factors (25)

https://www.patest.cn/contests/pat-a-practise/1059

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意:给出一个整数,按照从小到大的顺序输出其分解为质因数的乘法算式
分析:先建立个500000以内的素数表,然后从2开始一直判断是否为它的素数,如果是就将a=a/i继续判断i是否为a的素数,判断完成后输出这个素数因子和个数,用state判断是否输入过因子,输入过就要再前面输出“*”

#include <cstdio>
#include <vector>
using namespace std;
int main() {
	long int a;
	scanf("%ld", &a);
	printf("%ld=", a);
	if (a == 1) printf("1");
	bool state = false;
	for (int i = 2; a >= 2; i++) {
		int cnt = 0, flag = 0;
		while (a % i == 0) {
			cnt++;
			a = a / i;
			flag = 1;
		}
		if (flag) {
			if (state) printf("*");
			printf("%d", i);
			state = true;
		}
		if (cnt >= 2)
			printf("^%d", cnt);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值