PAT (Top Level) Practise 1002. Business (35)

1002. Business (35)

时间限制
800 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

As the manager of your company, you have to carefully consider, for each project, the time taken to finish it, the deadline, and the profit you can gain, in order to decide if your group should take this project. For example, given 3 projects as the following:

Project[1] takes 3 days, it must be finished in 3 days in order to gain 6 units of profit.Project[2] takes 2 days, it must be finished in 2 days in order to gain 3 units of profit.Project[3] takes 1 day only, it must be finished in 3 days in order to gain 4 units of profit.

You may take Project[1] to gain 6 units of profit. But if you take Project[2] first, then you will have 1 day left to complete Project[3] just in time, and hence gain 7 units of profit in total. Notice that once you decide to work on a project, you have to do it from beginning to the end without any interruption.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=50), and then followed by N lines of projects, each contains three numbers P, L, and D where P is the profit, L the lasting days of the project, and D the deadline. It is guaranteed that L is never more than D, and all the numbers are non-negative integers.

Output Specification:

For each test case, output in a line the maximum profit you can gain.

Sample Input:
4
7 1 3
10 2 3
6 1 2
5 1 1
Sample Output:
18
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=51;
struct node{
	int unite,consume,deadline;
	bool operator < (const node &a)const{
		return deadline<a.deadline;
	}
}v[maxn];
int main() {
	ios::sync_with_stdio(false);
	int n,maxd=0,res=0;
	cin>>n;
	for(int i=0;i<n;++i){
		cin>>v[i].unite>>v[i].consume>>v[i].deadline;
		maxd=max(maxd,v[i].deadline); 
	} 
	sort(v,v+n);
	vector<int> dp(maxd+1,0);
	for(int i=0;i<n;++i)
		for(int j=maxd;j>=v[i].consume;--j)
			if(j<=v[i].deadline){
				dp[j]=max(dp[j],dp[j-v[i].consume]+v[i].unite);
				res=max(dp[j],res);
			}
	cout<<res;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值