异常:程序包org.apache.http不存在 的问题解析

异常 专栏收录该内容
17 篇文章 0 订阅


异常:

Error:(19, 23) 错误: 程序包org.apache.http不存在
Error:(20, 23) 错误: 程序包org.apache.http不存在
Error:(21, 23) 错误: 程序包org.apache.http不存在
Error:(22, 30) 错误: 程序包org.apache.http.client不存在
Error:(23, 38) 错误: 程序包org.apache.http.client.methods不存在
Error:(24, 35) 错误: 程序包org.apache.http.impl.client不存在
Error:(175, 9) 错误: 找不到符号
符号:   类 HttpClient
位置: 类 SimpleWikiHelper
Error:(175, 33) 错误: 找不到符号
符号:   类 DefaultHttpClient
位置: 类 SimpleWikiHelper
Error:(176, 9) 错误: 找不到符号
符号:   类 HttpGet
位置: 类 SimpleWikiHelper
Error:(176, 31) 错误: 找不到符号
符号:   类 HttpGet
位置: 类 SimpleWikiHelper
Error:(180, 13) 错误: 找不到符号
符号:   类 HttpResponse
位置: 类 SimpleWikiHelper
Error:(183, 13) 错误: 找不到符号
符号:   类 StatusLine
位置: 类 SimpleWikiHelper
Error:(190, 13) 错误: 找不到符号
符号:   类 HttpEntity
位置: 类 SimpleWikiHelper


此异常的由来:


之前我的  compileSdkVersion 是21,然后为了与时代进步,更新了sdk版本等,更新到了23,,然而api23对应的安卓版本是6.0的,但是Android 6.0(api 23)已经不支持HttpClient了。然后就会大面积爆红,不要急,,,


解决办法:

build.gradle中 
在buildToolsVersion下边 
defaultConfig上边

添加如下代码:

  useLibrary 'org.apache.http.legacy'




  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

©️2022 CSDN 皮肤主题:编程工作室 设计师:CSDN官方博客 返回首页

打赏作者

哎呦不错哦啊呀嘿

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值