Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:10 -10 1 2 3 4 -5 -23 3 7 -21Sample Output:
10 1 4
思路:求最大子串和的变形,同时记录起点和重点
//最大子串和
#include <cstdio>
#include <algorithm>
using namespace std;
int k;
int arr[10010];
int main()
{
int sum = 0;
int max = 0;
scanf("%d", &k);
for (int i = 0; i < k; i++)
scanf("%d", &arr[i]);
for (int = 0; i < k; i++)
{
sum += arr[i];
if (sum > max)
max = sum;
if (sum < 0)
sum = 0;
}
printf("%d\n", max);
return 0;
}
本题在求出最大子串和的基础上再找到开始和终点位置,具体代码如下
#include <cstdio>
#include <algorithm>
using namespace std;
int k;
int arr[10010];
int main()
{
int sum = 0;
int max = -99999;
int star = 0, end = 0;
scanf("%d", &k);
for (int i = 0; i < k; i++)
{
scanf("%d", &arr[i]);
}
for (int i = 0; i <k ; i++)//求最大子串和 并记录终点位置
{
sum += arr[i];
if(sum>max)
{
max = sum;
end = arr[i];//终点值
}
if(sum<0)
sum = 0;
}
sum = 0;
for(int i=k-1;i>=0;i--)//倒序遍历,找到起点值
{
sum += arr[i];
if(sum==max)
star = arr[i];
if(sum<0)
sum = 0;
}
if(max<0)//如果全为负
printf("0 %d %d\n",arr[0],arr[k-1]);
else
printf("%d %d %d\n",max,star,end);
return 0;
}