King's Cake

http://acm.hdu.edu.cn/showproblem.php?pid=5640

King’s Cake

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1094 Accepted Submission(s): 762

Problem Description
It is the king’s birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1≤n,m≤10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.

Input
The first line contains a number T(T≤1000), the number of the testcases.

For each testcase, the first line and the only line contains two positive numbers n,m(1≤n,m≤10000).

Output
For each testcase, print a single number as the answer.

Sample Input
2
2 3
2 5

Sample Output
3
4

hint:
For the first testcase you can divide the into one cake of 2×2 , 2 cakes of 1×1

这个一直不对,最后才知道怎么回事。

#include<stdio.h>
#include<math.h>
int max(int a,int b);
int min(int a,int b);
int main()
{
    int T,n,m,num;
    scanf("%d",&T);
    while(T--)
    {
        num=1;
        scanf("%d%d",&n,&m);
        while(m==0)
        {
            m=max(n,m);
            n=min(n,m);
            num++;
            m=m-n;
        }
        printf("%d\n",num);
    }
}
int max(int a,int b)
{
    if(a>b)
        return a;
    else
        return b;
}
int min(int a,int b)
{
    if(a<b)
        return a;
    else
        return b;
}

其实第一个错的很明显,只是自己没发现。

m=max(n,m);
n=min(n,m);

如果m < n,设m=1,n=2,则最后m=2,n=2,并不是自己原来预料的结果。

这个是AC了的,修正了三四次吧,相比上一个要简单许多。

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int m,n,t,b,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int sum=1;
        a=max(n,m);
        b=min(n,m);
        while(b!=a)
        {

            b=min(a-b,b);
            a=max(a-b,b);
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值