poj 3197 Backward Digit Sums(DFS+穷举)

Backward Digit Sums

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4487 Accepted: 2575

 

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题解:给你一个数n,有n个数,从1-n,然后相邻的数相加得到下一组数,直到还有一个数为止,现在反过来求。

用穷举法,因为最后得到的是一个1-n的数组,所以可以用DFS,记录相加的值和所处位置,

            3+1+1+1+2+2+2+3 
        3+1+1+2       1+2+2+3 
   3+1          1+2        2+4
3         1            2             4

这样就知道每个位置加上几次了,用杨辉三角处理一下会很快的。

#include<cstdio>
#include <algorithm>  
#include <cstring> 
#define LL long long
using namespace std;
int c[15];
int f[15][15];
int vis[15];
int n,m,flag;
void DFS(int a,int sum)
{
	if(a==n&&sum==m)
	{
		flag=1;
		printf("%d",c[0]);
		for(int i=1;i<n;i++)
		{
			printf(" %d",c[i]);
		}
		printf("\n");
		return ;
	}
	if(flag||a>=n||sum>m)
	   return ;
	for(int i=1;i<=n;i++)
	{
		if(vis[i]==1)
		   continue;
		vis[i]=1;
		c[a]=i;
		DFS(a+1,sum+i*f[n-1][a]); //杨辉三角的妙用
		vis[i]=0;
	}
	 
}
int main()
{
	scanf("%d%d",&n,&m);
	flag=0;
	memset(vis,0,sizeof(vis));
	for(int i=0;i<n;i++)
		f[i][0]=f[i][i]=1;
	for(int i=2;i<n;i++)    //杨辉三角处理数组
	{
		for(int j=1;j<i;j++)
		{
			f[i][j]=f[i-1][j-1]+f[i-1][j];
		}
	}
	DFS(0,0);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值