Bone Collector 【01背包问题 java】

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

 

Sample Output

14

 

问题:输入t组数据,每组数组有两个输入N和V,代表N个石头,V是背包的容量,下面两组第一行是石头的价值,第二行是对应的重量,找到背包所能装下的最大价值。

 

简单的01背包问题,设f[v]表示容量为v的背包可以获得的最大价值,所以有:

for i=1..N
   for v=V..0
        f[v]=max{f[v],f[v-c[i]]+w[i]};
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int t = in.nextInt();
        while (t-- > 0) {
            int n = in.nextInt();
            int max = in.nextInt();

            int[] c = new int[n + 1];
            int[] v = new int[n + 1];

            for (int i = 1; i <= n; i++) {
                v[i] = in.nextInt();
            }
            for (int i = 1; i <= n; i++) {
                c[i] = in.nextInt();
            }
            //使用一维数组来表示
            int[] f = new int[max + 1];
            for (int i = 1; i <= n; i++) {
                for (int j = max; j >= c[i]; j--) {
                    f[j] = Math.max(f[j], f[j - c[i]] + v[i]);
                }
            }
            System.out.println(f[max]);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值