poj 1860

题目

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.  
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.  
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA  and C BA  - exchange rates and commissions when exchanging A to B and B to A respectively.  
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.  

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.  
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.  
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.  

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
题目要求就是每一行给出两个点,后面跟着四个浮点数代表a到b的转化率,a到b的手续费,b到a的转化率,b到a的手续费
一开始把手续费当作百分比的,然后wa了= =,后来才行知道不管转化多少钱都得交这些手续费。。。
这个题是用spfa算法做的,利用队列进行更新dist
这是自己手写的第一个spfa算法题,不是转载,纪念纪念- -,

代码如下,为了避免看我代码看不懂我做了注释

//728K	63MS
#include<iostream>
#include<vector>
#include<cstdio>
#include<queue>
using namespace std;
struct lu
{
    int endd;//连接的点
    float r,c;//r是转化率,c是手续费
    lu(int a,float rr,float cc){endd=a;r=rr;c=cc;}
};
float dist[105]={0};//将距离理解为钱就好,初始只有某种钱(x)多少元,其他位置都为0,最后比较x与初始钱数的大小来判断是否有正环
vector<lu>tu[105];
int n,m,v;
float q;
queue<int>dui;
bool vis[105]={0};//判断当前队列中是否有某点
bool spfa(int v)
{
    float y=dist[v];
    dui.push(v);
    vis[v]=!vis[v];
    while(!dui.empty())
    {
    int now=dui.front();dui.pop();
    for(int i=0;i<tu[now].size();++i)
    {
        int ed=tu[now][i].endd;
        if(dist[ed]<(dist[now]-tu[now][i].c)*tu[now][i].r)//如果这个点的钱数可以变成更大值,就进行更新
        {
            dist[ed]=(dist[now]-tu[now][i].c)*tu[now][i].r;
            if(!vis[ed]){dui.push(ed);vis[ed]=1;}//如果当前队列没有这个数,就把这个数加入队列,用这个数来对其他种类的钱数进行松弛
        }
    }
    vis[now]=!vis[now];//这个点操作完了,也pop了,就把vis进行标记为不在队列
    }
    if(dist[v]>y)return true;//最后判断一开始手里面的那种钱比最后多还是少,多就是存在正环
    else return false;
}
int main()
{
    int a,b;float rab,cab,rba,cba;
    scanf("%d%d%d%f",&n,&m,&v,&q);
    dist[v]=q;
    for(int i=0;i<m;++i)
    {
        scanf("%d%d%f%f%f%f",&a,&b,&rab,&cab,&rba,&cba);
        tu[a].push_back(lu(b,rab,cab));
        tu[b].push_back(lu(a,rba,cba));
    }
    bool flag=spfa(v);
    if(flag)cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
}

下面这个方法是上面这个程序的微改,速度由64MS变成了16MS
调整的地方在于找到自增环的时候自动退出程序...
这是我刚刚出去散步考虑的一种情况,如果a到b的手续费为0.01,转化率为2,同理b到a也一样,这样就会陷入一个循环,一直循环而找不到最大值
所以在第一次找到自增环就可以退出程序了。
代码如下

#include<iostream>
#include<vector>
#include<cstdio>
#include<queue>
using namespace std;
struct lu
{
    int endd;
    float r,c;
    lu(int a,float rr,float cc){endd=a;r=rr;c=cc;}
};
float dist[105]={0};
vector<lu>tu[105];
int n,m,v;
float q;
queue<int>dui;
bool vis[105]={0};
bool bellman_ford(int v)
{
    dui.push(v);
    vis[v]=!vis[v];
    while(!dui.empty())
    {
    int now=dui.front();dui.pop();
    for(int i=0;i<tu[now].size();++i)
    {
        int ed=tu[now][i].endd;
        if(dist[ed]<(dist[now]-tu[now][i].c)*tu[now][i].r)
        {
            dist[ed]=(dist[now]-tu[now][i].c)*tu[now][i].r;
            if(ed==v)return true;
            if(!vis[ed]){dui.push(ed);vis[ed]=1;}
        }
    }
    vis[now]=!vis[now];
    }
    return false;
}
int main()
{
    int a,b;float rab,cab,rba,cba;
    scanf("%d%d%d%f",&n,&m,&v,&q);
    dist[v]=q;
    for(int i=0;i<m;++i)
    {
        scanf("%d%d%f%f%f%f",&a,&b,&rab,&cab,&rba,&cba);
        tu[a].push_back(lu(b,rab,cab));
        tu[b].push_back(lu(a,rba,cba));
    }
    bool flag=bellman_ford(v);
    if(flag)cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的分类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的分析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与分析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常分类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值