There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
代码如下
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
const int maxn = 100;
using namespace std;
int m,n;
char a[maxn][maxn];
int dir[4][2]= {1,0,0,1,-1,0,0,-1};
int vis[maxn][maxn];
int sum;
int check(int x,int y)
{
if(x>=0&&y>=0&&x<n&&y<m&&a[x][y] == '.'&&vis[x][y] == 0)
return 1;
return 0;
}
void dfs(int x,int y)
{
if(vis[x][y] == 1) return;
int nx= 0,ny = 0;
vis[x][y] =1;
for(int i = 0; i<4; i++)
{
nx =x+ dir[i][0];
ny =y+dir[i][1];
if(check(nx,ny))
{
sum++;
dfs(nx,ny);
}
}
}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF &&(m+n))
{
memset(vis,0,sizeof(vis));
sum = 0;
for(int i = 0 ; i < n; i++)
{
getchar();
for(int j = 0; j < m; j++)
{
scanf("%c",&a[i][j]);
}
}
for(int i = 0 ; i <n; i++)
{
for(int j = 0; j < m; j++)
{
if(a[i][j] == '@')
{
int sx = i;
int sy = j;
a[i][j]='.';
dfs(i,j);
}
}
}
printf("%d\n",sum+1);
}
}