集训第十一天(2017/8/10):二分法练习和第四次做比赛

     今天是二分法专题第一天,感觉二分法比搜索简单多了,但是精度的控制还是要注意细节,比如说今天我做了一道题,输出结果跟答案老是差0.0001,怎么也检查不出来哪里错了,但答案就是不对,精度改了还是不对...

    还有今下午做比赛,第一题用到蔡勒公式???!!这是哪里出来的公式???还有一道深搜题老是做不出来,最后终于改对了。。。今天挺疲惫的(比赛累的)。

    贴上我怎么改都wrong answer的题吧:

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 51   Accepted Submission(s) : 24
Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


 

Sample Input
  
  
2 100 -4


 

Sample Output
  
  
1.6152 No solution!

AC代码:

#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>
using namespace std;
double cal(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double n;
        scanf("%lf",&n);
        if(cal(0)>n || cal(100)<n)
        {
            printf("No solution!\n");
            continue;
        }
        double l = 0.0,r = 100.0;
        double mid = (l+r)/2;
        while(fabs(cal(mid)-n)>1e-5)
        {
            if(cal(mid)>n)
                r = mid-1;
            else
                l = mid+1;
            mid = (l+r)/2;
        }
        printf("%.4f\n",mid);
    }

    return 0;
}

 

 

我的代码(不知道哪里出错了):

/*#include<iostream>
#include<iomanip>
#include<cmath>
#include<cstdio>
using namespace std;

double y;
double f(double x)
{
    return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6-y);
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {   double x;
        double l,r,xx;
        cin>>y;
        if(f(0)>0||f(100)<0) cout<<"No solution!"<<endl;
        for(x=0;x<=100;x++)
        {
            l=x;r=x+1;
            if(f(l)==0)
                printf("%.4lf",l);
            else if(f(l)*f(r)<0)
            {
                while(r-l>=0.00001)
                {
                    xx=(r+l)/2;
                    if((f(l)*f(xx))<=0)r=xx;
                    else l=xx;
                }

            cout<<fixed<<setprecision(4)<<l<<endl;
            }
        }
    }
    return 0;
}

我的(错误)输出(输入100,输出的是1.6151)

而正确的是1.6152!哪位大神帮我看看...

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值