Wireless Network
Time Limit: 10000MS | Memory Limit: 65536K | |
Total Submissions: 48747 | Accepted: 19950 |
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1 0 1 0 2 0 3 0 4 O 1 O 2 O 4 S 1 4 O 3 S 1 4
Sample Output
FAIL SUCCESS
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<queue>
#include<unordered_set>
#include<cmath>
#define eps 1e-6
using namespace std;
int N, d;
const int MAX_N = 1005;
char Control[2];
struct Point {
int x, y;
};
Point _point[MAX_N];
int par[MAX_N];
unordered_set<int> Repaired;
void init(int n) {
for (int i = 1; i <= N; i++) {
par[i] = i;
}
}
int find(int x) {
if (par[x] == x) {
return x;
}
else {
return par[x] == find(par[x]);
}
}
void unite(int x, int y) {
x = find(x);
y = find(y);
if (x == y) {
return;
}
else {
par[y] = x;
}
}
double distance(Point a, Point b) {
return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}
bool Same(int x, int y) {
return par[x] == par[y];
}
int main() {
scanf("%d%d", &N, &d);
init(N);
for (int i = 1; i <= N; i++) {
scanf("%d%d", &_point[i].x, &_point[i].y);
}
while (scanf("%s", Control) != EOF) {
if (Control[0] == 'O') {
int index;
scanf("%d", &index);
for (auto item : Repaired) {
if (distance(_point[item], _point[index]) <= d + eps){
unite(item, index);
}
}
Repaired.insert(index);
}
if (Control[0] == 'S') {
int index1, index2;
scanf("%d%d", &index1, &index2);
if (Same(index1, index2)) {
printf("SUCCESS\n");
}
else {
printf("FAIL\n");
}
}
}
system("pause");
return 0;
}
Tips:
注意这道题的输入输出处理,当一些测试用例很特殊的处理方式