nefuoj67-思维-自动求循环节

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5

在设置cnt的时候,不能把他(以后做除数)初始化为0,如果这样就错,虽然他在日后的计算中肯定要被赋值,肯定会被赋值成其他数,但是还是re。。如果不赋值的话就不会错。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
/*自动求循环节。
*/
using namespace std;
int a[501];
int cnt;
int main()
{   int a1,b;int n;
    while(~scanf("%d%d%d",&a1,&b,&n))
    {  //int cnt=0;
        memset(a,0,sizeof(a));
        if(b==0&&a1==0&&n==0) break;
         if(n<3){
            printf("1\n");
              continue;
         }
        a[1]=1;a[2]=1;
   for(int i=3;i<=500;i++)
     {a[i]=((a1*a[i-1])%7+(b*a[i-2])%7)%7;
      if(a[i]==1&&a[i-1]==1)
      {
        cnt=i-2;
        break;}
     }
    int x=n%cnt;
     if(x==0) cout<<a[cnt]<<endl;
   else
   printf("%d\n",a[x]);
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值