Financial Management
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 187040 Accepted: 71060
DescriptionLarry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output
$1581.42
Source
Mid-Atlantic 2001
还以为是单位的问题,傻,查了才知道原来Penny是分,和数学里的保留两位小数是同个意思。
double的输入为“%lf”,输出为“%f”
我是萌新吗!!!
附上代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
double n,sum=0.0;
for(int i=1;i<=12;i++)
{
scanf("%lf",&n);
sum+=n;
}
printf("$%.2f\n",sum/12.00);
return 0;
}